0

I am not new to Linux, but am "retooling" and getting back into the LAMP model and working to get everything configured and setup for my environment.

I am currently in the process of completing the installation and configuration of Ubuntu 16.04 (and MySQL 5.7)

I have installed MySQL Workbench v 6.3 on a local windows 10 box while Linux running on a remote box and MySQL on the same box as the remote. This is all taking place within the same firewall so I am not sending traffic outside of the firewall.

The problem is when I try to connect to the MySQL server from Workbench, I get the error message “Failed to Coinnect to MySQL at 127.0.0.1:3306 with root user.

Things that have been checked

  • I can connect to MySQL while in an SSH session using Putty from the Windows 10 box and look at the tables that were setup during the MySQL install.
  • I was able to create user accounts while in MySQL. So, I know MySQL is running.
  • I can ping 127.0.0.1 in the SSH session and I get confirmation the ping arrived at the address provided.

  • I have checked the mysqld.cnf in the /etc/mysql/mysql.conf.d/ directory for the bind-address which is = 127.0.0.1.

So, any help anyone can provide for resolution would be appreciated.

0

You need to have MySQL listen on an interface that the other PC can access.

At the moment it is only listening on 127.0.0.1, which is the interface only the local machine and clients over SSH can access

If you set it to 0.0.0.0 it will listen on all interfaces instead, so the other machine will be able to connect to it, assuming the machine firewalls are configured correctly.

  • i have updated the ip address and set it to 0.0.0.0 and checked the status of the firewall. On the Lunix box the status shows inactive after I ran the sudo ufw status and on the Windows box I turned the firewall off (I know this is not the smartest thing, but using process of elimination I am hoping I will have success connecting). However, this still will not allow a connection from MySQL workbench. – David Rasmussen Sep 6 '17 at 0:27
  • I have now installed mysql-workbench on the Linux box that is running mysql and was able to connect to mysql and start to create schemas, tables etc... As I stated in my previous post I have taken the firewalls out of the equation but still not joy. Any suggestions as to how to fix the issue of connecting from a remote box would be appreciated. – David Rasmussen Sep 6 '17 at 12:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.