11

I'm running Ubuntu Server 16.04.3 LTS VirtualBox VM with XFCE as desktop environment. Used VirtualBox is latest version 5.1.26 r117224. Frequently the mouse cursor is running out of sync and the only way I can fix it is restarting the VM. Can someone propose persistent solution for this problem?

1
  • 2
    I found that exiting full screen mode and entering it again also solves the problem without restarting the VM.
    – bobeff
    Commented Sep 5, 2017 at 9:12

9 Answers 9

7

I had the same problem, however I was able to solve it doing the following :

  1. In Virtualbox → Machine Settings → System → Motherboard I changed Pointing Device to "PS/2 Mouse"

  2. In the hosted Ubuntu VM (Xubuntu in my case) go to Mouse and Touchpad change "Device" to "VirtualBox mouse integration"

That solved my issue and my mouse back to work normal.

2
  • With PS2 mouse it is better: mouse is there where I can see it. If I click on it it acts exactly there. But sometimes I can't go to the top of the window with the mouse. It jumps outside VirtualBox instead. If I'm right I need to go to the bottom of the virtual screen than I can go to the top then. Well, not Ubuntu, but Fedora 38, and VirtualBox 7.0. Commented Sep 4, 2023 at 17:28
  • With Ubuntu 22.04.1 and VirtualBox 7.0.12 this problem still exists, but setting the mouse to PS/2 seems to help. Thanks for the hint.
    – kcbehler
    Commented May 22 at 0:47
7

I had the same problem, that the mouse pointer was offset running out of sync. My VirtualBox Ubuntu is running in Window Mode (not full-screen).

My solution:

  • Resizing the VirtualBox window
  • Then maximize the window

enter image description here

3

The problem I'm experiencing is when running 2 monitors hosted by a Windows 10 machine, the mouse no longer functions properly.

Full Description of Problem: I have installed Windows 10 for my Mac book pro with the help of a virtual box and connecting to two virtual screens. Mouse when being used is responding weirdly, however, they are offset. With 2 monitor setup, the mouse clicks are less offset. When I click on the first screen it reflects to the second screen and wise versa. The mouse pointing is the completely indifferent direction.

when I have two virtual screens. There seems to be a strange offset on the mouse pointer. Without Mouse Integration it works fine on multiple screens but that has other drawbacks that are very very slow responses. Please try to help me with this issue to resolve.

Potential solutions are the following,

  1. Run a single monitor. (Mouse pointer works fine)
  2. Run dual monitors (Mouse pointer completely broke and not working properly)
2

I was also struggling with the same problem, but I finally found a solution with by following these steps:

On the VirtualBox menu bar → DevicesInsert guest additions cd image... → Run the code and press Enter.

1
  • Yes! This worked. Note, the "insert guest additions cd image" seems to be broken since 6.0, but you can wget the URL it displays (inside the guest) and then run the ISO using the GUI.
    – cag51
    Commented Jun 10, 2022 at 23:24
1

I've had the same occasionally, with Kubuntu 16.04 in Virtualbox 5.2 running within Windows 10. Turning 'Devices>Mouse Integration' off and on again fixed it.

Resizing the host window had no effect for me and changing the pointing device while the VM was running wasn't possible. I've not tried full screen on this occasion, but it certainly seems like a viable fix, as it appears to reset mouse integration.

1

Changing the screen resolution and revert back to the original screen resolution helped in my case.

1

Here is what worked for me:

  • change virtual machine (Ubuntu) to 'full screen mode' (this part is the same as eboarder answer above). This already solves the mouse calibration. This is how it looks like on my Mac: enter image description here Step 2: enter image description here

  • you can now change back to 'window mode', mouse will still be calibrated, at least according to my experience, so you do not have to stay in full screen if you do not like it. See below: enter image description here

I hope this helps.

1

I had same issue. Finally I had remove it from stretch mode and issue got resolved. (Move to full screen mode is much better). Before that I tried to so many things with VM settings but nothing helped me.

0

Try using the key combination recommended in the dialog below, Host + C:

VirtualBox Screen Mode Warning dialog

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .