0

This question already has an answer here:

I have installed ubuntu 16.04 for hp pavilion 15-au172tx laptop but wifi did not work. This laptop is 7th gen and is there any problem with it? I also tried to get wifi adapter type but i can't and i also tried additional driver application to add drivers but wifi adapter is not see in that application. Please help me

Output of lspci -knn | grep Net -A3; uname -a

05:00.0 Network controller [0280]: Intel Corporation Device [8086:24fb] (rev 10)
    DeviceName: Intel Dual BandWireless-AC 3168 802.11 ac 1x1 WiFi + BT 4.0 Combo Adapter
    Subsystem: Intel Corporation Device [8086:2110]
Linux HP-Pavilion-Notebook 4.4.0-93-generic #116-Ubuntu SMP Fri Aug 11 21:17:51 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

marked as duplicate by Pilot6, Eric Carvalho, Charles Green, karel, Yaron Sep 5 '17 at 8:03

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Please edit your question and add output of lspci -knn | grep Net -A3; uname -a terminal command. – Pilot6 Sep 4 '17 at 14:45
  • i have upload that – supun rajasinghe Sep 4 '17 at 15:05
  • Post output as text, not as a screenshot. You need to upgrade kernel. If you installed 16.04.3, it would immediately work. – Pilot6 Sep 4 '17 at 15:10
1

Connect to internet by wire and run

sudo apt update
sudo apt install linux-generic-hwe-16.04 linux-firmware

and reboot.

This device is supported by newer kernels.

Not the answer you're looking for? Browse other questions tagged or ask your own question.