0

I am trying to install Ubuntu on a fresh 3TB hard drive.

I have tried the following

  • this linuxquestions thread

  • making all partitions Ext4

  • installing Ubuntu 14 and 16.04 since later OSs may be better able to handle large hard drives
  • run [Boot-Repair](https:// help.ubuntu.com/community/Boot-Repair), and tried several different ways to set up this hard drive from the installation dialogue. (I can enumerate them if that's helps, and the results of my attempts with Boot-Repair are here.)
  • This Ask Ubuntu question: Unable to boot 12.04 after install on 3TB drive,

I tried to partition the drive into spaces of less than 2 GB, but to no avail.

I note from [this article on nzgeek](http:// nzgeek.org/topic/54247/partition-setup-for-ubuntu-on-2tb-disk-gpt), for example, that it appears I'm not the only one. Still, I am not a Linux (or even a computer) expert and I have no idea how to proceed.

8
  • 1
    Have you installed a fresh GPT partition table?
    – heynnema
    Sep 4 '17 at 1:27
  • does the hardware support >2TB drives. I've some dual & quad core hardware that has a 2TB (drive) limit set by hardware; so I know its pointless to expect any OS to use more than 2TB on a larger drive as the drive params passed to the OS are limited to 2TB values. Your issue may have NULL to do with ubuntu - but be a hardware issue.
    – guiverc
    Sep 4 '17 at 2:18
  • Did you install a 32 bit or 64 bit release?
    – ubfan1
    Sep 4 '17 at 2:24
  • heynnema, yes, I tried using the native functions in the Ubuntu install to reformat ("Erase disk and fresh install") the drive and also tried using both fdisk and gfdisk to repartition it. ubfan, all attempts were with creating a 64bit release. Finally, guiverc, that may be the case. Would you please let me know how I could find this out? Thank you all for help!
    – wesamuels
    Sep 4 '17 at 3:55
  • You'll still need to use gparted to lay down a fresh GPT partition table prior to doing an erase disk and fresh install. Report back after doing so.
    – heynnema
    Sep 4 '17 at 4:10
0

If you don't have any data on the 3TB Hard Drive, then, you should reinstall Ubuntu(fresh install). GRUB may not support such big size of root partition yet, so after you format your hard drive (Only do this if you don't have any data on you hard drive!!!), you should make a root partition of size from 700GB to 1TB(The smaller the better) and try again.
You should definitely use an LTS(Long Term Support) Version of Ubuntu because it, as the name suggests, has long term support.

3
  • In my latest attempt, I did try to break up the huge partitions into ones less than 2TB. fdisk -l for that drive currently returns: Device Start End Sectors Size Type /dev/sda1 2048 4095 2048 1M BIOS boot /dev/sda2 4096 1003519 999424 488M Linux filesystem /dev/sda3 1003520 3616493567 3615490048 1.7T Linux LVM /dev/sda4 3616493568 5860533134 2244039567 1T Linux LVM Did I do it incorrectly to try to overcome this possible issue?
    – wesamuels
    Sep 4 '17 at 4:17
  • @wesamuels, 1. Please edit your original question to show output from commands. Indent each line 4 spaces in order to render it as code. That way it is much easier for us to read :-) -- 2. Did I understand correctly, that you can install Ubuntu now (a step forward), but the computer cannot boot into the installed system? -- 3. Is the 3TB drive the only drive, or is there another (internal) drive in the computer?
    – sudodus
    Sep 4 '17 at 10:13
  • Updating the BIOS solved the issue. Thank you all--gals and guys--for your help with this. I really appreciate your quick, knowledgeable, and friendly support!
    – wesamuels
    Sep 10 '17 at 1:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.