I have a brand new Dell XPS 15 with Windows installed on it. I am trying to install a dual boot using a USB stick and am having some trouble.

I am getting past both of "do you want to install 3rd party libraries?" screen and the "select wifi screen". When I get to the "select your partition" screen, no partitions appear. There is nothing to select. When I click the "+", "-", or "change" buttons the screen froze and I cannot do anything. I also cannot select the "New Partition" button because it is grayed out. I have installed Ubuntu on a couple devices at this point and this is the first issue I have ever encountered.

I tried using unetbootin as well as Rufus to load the image onto the usb drive to only get the same result.

I am getting a weird error though on a previous screen that maybe have something to do with it. The error is something like ACPI Error: [\_SB_.PCI0.XHC_.RHUB.HS11] Namespace lookup failure, AE_Not_Found

When I select "Try Ubuntu" and run sudo lsblk -f in commandline I get the following...

Can someone throw me a bone please? Thanks.

  • @DavidFoerster Just did. Check it out. – Erik Åsland Sep 4 '17 at 16:45
  • 1
    In addition to change to AHCI as below in heynnema post, many Dell users have had to update Dell's UEFI and firmware on NVMe drive. Dell XPS 13 9360 16.04 worked after nvme firmware & BIOS update, 16.10 did not, new rEFInd for NVMe askubuntu.com/questions/884991/… & Dell UEFI Dual boot instructions using Something Else dell.com/support/article/us/en/19/SLN301754/… – oldfred Sep 4 '17 at 18:50
  • In future, could you please post text files, dialogue messages, and program output listings as text, not as images? To achieve the latter two you can either 1) select, copy & paste the dialogue text or terminal content or 2) save the program output to a file and use that. Longer listings (the editor will tell you what's too long) should be uploaded to a pastie service and linked to in the question. Thanks. – David Foerster Sep 9 '17 at 10:31

This should apply to the XPS 15 also... in the BIOS, your disk is set to RAID, and Ubuntu can't install on RAID.

Make sure to have a backup of your important Windows files!

You've got a single SSD/HDD set up in RAID mode, and the Ubuntu installer won't recognize your SSD/HDD until you switch your disk setting in the BIOS from RAID to AHCI.

Making that switch comes with some problems though, as Windows will no longer boot. Looking at this article https://samnicholls.net/2016/01/14/how-to-switch-sata-raid-to-ahci-windows-10-xps-13/ will show you how to make the change without having to reinstall Windows.

Boot to Windows with your current SATA controller configuration
Open Device Manager
Expand Storage Controllers and identify the Intel SATA RAID Controller
View properties of the identified controller
On the Driver tab, click the Update driver… button
Browse my computer…, Let me pick…
Uncheck Show compatible hardware
Select Microsoft as manufacturer
Select Microsoft Storage Spaces Controller as model3
Accept that Windows cannot confirm that this driver is compatible
Save changes, reboot to BIOS and change RAID SATA Controller to AHCI
Save changes and reboot normally, hopefully to Windows

Now you should be able to install Ubuntu in a dual-boot configuration.

ps: Also see http://triplescomputers.com/blog/uncategorized/solution-switch-windows-10-from-raidide-to-ahci-operation/

  • just rebooting into Windows safe mode with networking nd letting it install AHCI drivers worked. Since that, both Windows and Linux work fine. – bluppfisk Sep 4 '17 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.