6

I have set /etc/default/grub to:

GRUB_HIDDEN_TIMEOUT=0
GRUB_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_CMDLINE_LINUX_DEFAULT=""
GRUB_CMDLINE_LINUX=""

so that I get the full console text output during boot.

In addition, I have set /etc/default/console-setup to:

FONTFACE="TerminusBold"
FONTSIZE="16x32"

so that the fonts during boot are larger.

So, now when I boot (using legacy CSM mode and integrated Intel Skylake graphics), the following happens:

  1. I see the ASRock UEFI boot logo of the mainboard at the native resolution of the monitor (1920x1080)
  2. Then the monitor goes blank and seems to switch modes
  3. Then the console output appears on the monitor in the monitors native resolution (1920x1080) but the console uses the small default fontsize
  4. Then, while the console output is on the screen, the monitor goes blank again and seems to switch modes again
  5. Then the console output reappears in the native resolution of the monitor (1920x1080) and then switches to the larger font size

So, I am wondering: Why does the screen go blank a few times, even though the resolution stays the same all the time?

And why isn't the console using the larger font size immediately?

Also, according to the Arch Linux Wiki, it seems to be possible to have KMS (Kernel Mode Setting) activate earlier than usually, by editing /etc/mkinitcpio.conf, see:

Kernel mode setting - Early KMS start | ArchWiki

But /etc/mkinitcpio.conf does not seem to be available on Ubuntu.

How can KMS be enabled early on Ubuntu?

0

I am not aware which driver your system is running, for the corresponding module.

  1. Add it to

    /etc/initramfs-tools/modules
    
  2. Update the current kernel RAMDisk using

    sudo update-initramfs -u
    

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.