4

I'm trying to remove pip (because I have pip3). I did sudo apt-get remove --purge pip, and get

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package pip

But which pip gives

/usr/local/bin/pip

I can confirm that pip doesn't work, because pip --version gives

bash: /usr/local/bin/pip: /usr/bin/python: bad interpreter: No such file or directory

How to I clean up my system?

FYI I'm using Ubuntu on Windows (WSL). I really hope this isn't the problem, because everything else seems to be working fine.

  • There is no package named pip. Probably you have python-pip package. (though WSL may be different..? – doug Sep 3 '17 at 0:08
  • @doug I also tried sudo apt-get remove python-pip, doesn't work. – ved Sep 3 '17 at 0:29
  • Have you tried apt list | grep pip to find the package name? – WinEunuuchs2Unix Oct 8 '17 at 0:07
0

Because you have pip3, you need to uninstall python3-pip.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.