0

At my wits end, dont know what i've done wrong.

I have recently moved house and had a number of things wrong with my ubuntu server.

  • I have new network hardware (ubiquiti gateway and switch)
  • My initial issue was my laptop wouldnt allow me to connect to server using ssh, complained about the key and known_hosts. I removed that file but now when i get asked for my password on the server it just wont accept it and it's definitely right
  • None of my daemon services running on the server can be connected to from my browser on my laptop (sickrage, plex, ubiquiti controller software, deluge web) I just get a connection refused error
  • Something else I noticed when i login directly onto the ubuntu server, I get an error "failed to connect to http://changelogs.ubuntu... check your internet connection or proxy settings"

I have done two things in the last few days --I installed OpenVPN and followed these instructions to create split vpn tunneling for deluge https://www.htpcguides.com/force-torrent-traffic-vpn-split-tunnel-debian-8-ubuntu-16-04/ ***I tried undoing most of this but it doesnt seem to have helped

--I moved and have new network gear and new internet connection

*** ok interesting new bit of information, if i reboot my server, the first connection i make to the server whether it's to a web base daemon like sickrage, ubiquiti controller, plex media server, the service loads on my macs browser, but if i hit refresh in the browser, it fails to connect and never connects again unless i reboot server

If i try SSH from mac to server it sometimes works but soon after i get a "packet_write_wait: Connection to 192.168.0.6: Broken pipe" and then can never connect again until i reboot the server...

it's almost like a service crashes that effects network services?

0

Similar symptoms show up if one has same IP adress on two machines in network. Not very probable, though.

Do you have a headless server (no keyboard, no mouse, no monitor? Or can you sit in front of it and log in. In this case commands like ifconfig, ps -ef | grep ssh and netstat -anmight give you a clue what's going on.

"password is definitely right" - is there any chance that you are connecting to another server than you are thinking you are? Maybe the new network equipment is generously distributing new IP addresses via DHCP?

Well, just some ideas. TomTomTom

| improve this answer | |
  • Thanks Tom! Sounds like IP address issues were the cause, I did so many different things to try fix it I'm not sure what fixed it in the end. Tried undoing the openvpn setup, plugged in my old router, reset the new network gear (default ip ranges) – Rich J Sep 7 '17 at 4:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.