Some of my speakers are not working and hence sound output even in VLC is below average. Bottom firing speakers are mediocre. I found an answer on this site for a Dell laptop, and the config was a little different which confused me.

I am new to Linux and just dual-booted my laptop for college purposes and coding.

The solution I found uses HDAJackRetask GUI from the alsa-tools-gui package.

In the application I ticked show unconnected pins and attempted to use trial and error to find a working combination. I had the B/O front firing speakers working through overriding and setting all pins as internal speakers, but could not find a working configuration for the subwoofer. Can anyone suggest a suitable configuration?

I'm using Ubuntu 17.04.

Screamshot for HDAJackRetask GUI config for my pc

  • Install pavucontrol and inspect which profiles are associated to your audio device. Go to Configuration tab and switch among them to see which of them will work better.
    – Redbob
    Sep 2, 2017 at 15:02
  • 'pacmd set-card-profile 2 output:analog-stereo' Used this command at terminal and front firing speakers started working but subwoofer is still not working.....
    – PS_314
    Sep 2, 2017 at 15:38
  • Did you opened pavucontrol and set your profile to Analog Sorround 5.1 output as I pasted this image: dropbox.com/s/ocnu3kvkuwlm80t/…
    – Redbob
    Sep 2, 2017 at 16:50
  • After using pulse audio the output is certainly better. The analog stereo 4.0 worked best. The 5.1 option didn't gave any output at all. Thanks anyway. And default setting before 4.0 was analog stereo only without surround, I think that was creating the problem.
    – PS_314
    Sep 3, 2017 at 12:08
  • Same issue. The solution on reddit is the way to go, but I can't find the specifics for my laptop. Mine is ALC295.
    – swingcake
    Jul 5, 2018 at 12:51

1 Answer 1


After clicking through a bunch of links I found a solution that worked for me (HP Pavilion with Ubuntu 20.04, bass speaker was not working). The following answer is copied verbatim from https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1648183. I'm copying it here since this link showed up first when I searched. I'm intentionally leaving in the usernames since I am not the one who solved this problem:

Robert Joynt (robertjjoynt) wrote on 2017-05-17:

I've managed to fix this problem on my machine (HP Omen 15 running Ubuntu 17.04 using codec for Realtek ALC295 sound device). To fix the problem, I can do the following:

Install alsa-tools if not installed:

sudo apt install alsa-tools

Create and save a script in /usr/local/bin:

hda-verb /dev/snd/hwC0D0 0x20 SET_COEF_INDEX 0x67
hda-verb /dev/snd/hwC0D0 0x20 SET_PROC_COEF 0x3000

Run the script as root in a terminal to immediately fix the problem.

To run the script on startup, use cron with the @reboot command:

sudo crontab -e

and then add line in crontab:

@reboot [full path to script]

To run script on resume from suspend, copy the script to /lib/systemd/system-sleep

For more technical details regarding this fix, see https://bugzilla.kernel.org/show_bug.cgi?id=195457

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.