0

Now when I try to install anything this happen there is a problem with nginx and I don't know how to fix it.

  -----@----:~$ sudo apt-get install nginx
  [sudo] password for _____: 
  Reading package lists... Done
  Building dependency tree       
  Reading state information... Done


  The following packages were automatically installed and are no longer 
  required:
  account-plugin-tools account-plugin-ubuntuone colobot-common
  colobot-common-sounds colobot-common-textures libboost-locale1.58.0
  libgsm1:i386 libllvm3.8 libllvm3.8:i386 libmircommon5 libmircommon6
  libmirplatform11 libmirplatform13 libmirserver38 libodbc1:i386 libpay2
  libphysfs1 libpoppler-qt5-1 libqt5bluetooth5 libqt5bluetooth5-bin
  libqt5keychain0 libqt5location5 libqt5location5-plugins
  libqt5positioning5-plugins libqt5purchasing5 libqt5quickparticles5
  libqt5versitorganizer5 libqt5websockets5 libsdl-ttf2.0-0 libu1db-qt5-3
  libubuntu-app-launch2 libubuntu-location-service3      libubuntuoneauth-2.0-0
 libzmqpp3 linux-headers-4.4.0-62 linux-headers-4.4.0-62-generic
 linux-headers-4.4.0-66 linux-headers-4.4.0-66-generic linux-headers-     4.4.0-70
 linux-headers-4.4.0-70-generic linux-headers-4.4.0-72
 linux-headers-4.4.0-72-generic linux-image-4.4.0-62-generic
 linux-image-4.4.0-66-generic linux-image-4.4.0-70-generic
 linux-image-4.4.0-72-generic linux-image-extra-4.4.0-62-generic
 linux-image-extra-4.4.0-66-generic linux-image-extra-4.4.0-70-generic
 linux-image-extra-4.4.0-72-generic linux-signed-image-4.4.0-62-generic
 linux-signed-image-4.4.0-66-generic linux-signed-image-4.4.0-70-generic
 linux-signed-image-4.4.0-72-generic mir-client-platform-mesa5
 -graphics-drivers-desktop mir-platform-graphics-mesa-kms12
 mir-platform-graphics-mesa-kms8 mir-platform-graphics-mesa-x12
 mir-platform-graphics-mesa-x8 mir-platform-input-evdev5
 mir-platform-input-evdev6 pay-service pay-ui pinball-data policykit-unity8
python3-gnupg qml-module-pamauthentication0.1 qml-module-qmltermwidget1.0
 qml-module-qt-websockets qml-module-qtbluetooth qml-module-qtlocation
qml-module-qtorganizer qml-module-qtpositioning qml-module-qtpurchasing
qml-module-qtquick-localstorage qml-module-qtquick-particles2

q ml-module-qtsensors qml-module-qtwebsockets qml-module-ubuntu-mediascanner0.1 qml-module-ubuntu-ui-extras-browser qml-module-ubuntuone qtdeclarative5-poppler1.0 qtdeclarative5-u1db1.0 qtdeclarative5-ubuntu-mediascanner0.1 qtdeclarative5-ubuntu-push-plugin qtdeclarative5-ubuntu-syncmonitor0.1 qtdeclarative5-ubuntu-telephony-phonenumber0.1 qtdeclarative5-ubuntu-thumbnailer0.1 qtdeclarative5-ubuntu-ui-extras-browser-plugin qtdeclarative5-ubuntu-web-plugin qtdeclarative5-usermetrics0.1 qtubuntu-appmenutheme qtubuntu-desktop qtubuntu-print signon-plugin-password snap-confine system-image-common system-image-dbus ubuntu-application-api3-desktop ubuntu-html5-ui-toolkit ubuntu-printing-app ubuntu-push-client ubuntu-sdk-libs ubuntu-terminal-app ubuntuone-client-data ubuntuone-credentials-common unity-scope-click unity-scope-click-departmentsdb unity8-desktop-session unity8-desktop-session-mir wine-devel wine-devel-amd64 wine-devel-i386:i386 Use 'sudo apt autoremove' to remove them. The following NEW packages will be installed: nginx 0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded. 1 not fully installed or removed. Need to get 3,490 B of archives. After this operation, 37.9 kB of additional disk space will be used. Get:1 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 nginx a ll 1.10.3-0ubuntu0.16.04.2 [3,490 B] Fetched 3,490 B in 0s (6,533 B/s) Selecting previously unselected package nginx. (Reading database ... 558722 files and directories currently installed.) Preparing to unpack .../nginx_1.10.3-0ubuntu0.16.04.2_all.deb ...
Unpacking nginx (1.10.3-0ubuntu0.16.04.2) ... Setting up nginx-core (1.10.3-0ubuntu0.16.04.2) ... Job for nginx.service failed because the control process exited with error code. See "systemctl status nginx.service" and "journalctl -xe" for details. 'invoke-rc.d: initscript nginx, action "start" failed. ● nginx.service - A high performance web server and a reverse proxy server Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled) Active: failed (Result: exit-code) since Thu 2017-08-31 18:09:43 EDT; 11ms ago Process: 32582 ExecStart=/usr/sbin/nginx -g daemon on; master_process on; (code=exited, status=1/FAILURE) Process: 32578 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=0/SUCCESS)

Aug 31 18:09:40 Reimann nginx[32582]: nginx: [emerg] bind() to 0.0.0.0:80 f...e) Aug 31 18:09:40 Reimann nginx[32582]: nginx: [emerg] bind() to 0.0.0.0:80 f...e) Aug 31 18:09:41 Reimann nginx[32582]: nginx: [emerg] bind() to 0.0.0.0:80 f...e) Aug 31 18:09:41 Reimann nginx[32582]: nginx: [emerg] bind() to 0.0.0.0:80 f...e) Aug 31 18:09:42 Reimann nginx[32582]: nginx: [emerg] bind() to 0.0.0.0:80 f...e) Aug 31 18:09:42 Reimann nginx[32582]: nginx: [emerg] still could not bind() Aug 31 18:09:43 Reimann systemd[1]: nginx.service: Control process exited, ...=1 Aug 31 18:09:43 Reimann systemd[1]: Failed to start A high performance web ...r. Aug 31 18:09:43 Reimann systemd[1]: nginx.service: Unit entered failed state. Aug 31 18:09:43 Reimann systemd[1]: nginx.service: Failed with result 'exit...'.' Hint: Some lines were ellipsized, use -l to show in full. dpkg: error processing package nginx-core (--configure): subprocess installed post-installation script returned error exit status 1 dpkg: dependency problems prevent configuration of nginx: nginx depends on nginx-core (>= 1.10.3-0ubuntu0.16.04.2) | nginx-full (>= 1.10.3-0ubuntu0.16.04.2) | nginx-light (>= 1.10.3-0ubuntu0.16.04.2) | nginx-extras (>= 1.10.3-0ubuntu0.16.04.2); however: Package nginx-core is not configured yet. Package nginx-full is not installed. Package nginx-light is not installed. Package nginx-extras is not installed. nginx depends on nginx-core (<< 1.10.3-0ubuntu0.16.04.2.1~) | nginx-full (<< 1.10.3-0ubuntu0.16.04.2.1~) | nginx-light (<< 1.10.3-0ubuntu0.16.04.2.1~) | nginx-extras (<< 1.10.3-0ubuntu0.16.04.2.1~); however: Package nginx-core is not configured yet. Package nginx-full is not installed. Package nginx-light is not installed. Package nginx-extras is not installed.

  dpkg: error processing package nginx (--configure):
  dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                        Errors were encountered while processing:
nginx-core
nginx
E: Sub-process /usr/bin/dpkg returned an error code (1)

-------@------:~$ so the question is what did I destroy inadvertently I ran

sudo apt-get -f install and get similar errors

1

Dependency errors created by apt-get can usually be solved by running sudo apt-get -f install. If that doesn't solve the issue, edit your question.

  • I tryed that before posting the question and I got the same error message – Riemann-bitcoin. Sep 1 '17 at 12:15

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.