I have created an ubuntu 10.04 cloud server on the Amazon cloud (EC2) I am encountering a stalled LAMP install each time I try it. I've created about 5 fresh instances. Each time The installation gets stuck at 79% on the "configuring mysql-server-5.1" portion of the install.

First I do an update (sudo apt-get update) then an upgrade (sudo apt-get upgrade) then try to install the lamp using tasksel.

I've done this before on a rackspace cloud server and it works fine. Every single attempt fails on EC2 instances. I will contact Amazon but I am also asking here in case it is an ubuntu specific issue and possibly a known issue that someone can guide me towards solving.

The region is EU West (Ireland). The AMI Id is ami-00e9d874. The instance type is m1.large.

I've tried several different AMIs though (all ubuntu x64 10.04)

  • Please provide more info: EC2 region, AMI id, instance type. – Eric Hammond Jan 13 '12 at 18:35
  • provided with edit. – MrVimes Jan 14 '12 at 0:24

If you start with a standard Ubuntu 10.04 AMI published by Canonical, then installing LAMP with tasksel works just fine. For us-west-1, the latest 64-bit 10.04 AMI is ami-81dde2f5.

The AMI you specified (ami-00e9d874) is a BitNami AMI. It looks like BitNami already has MySQL installed on that AMI using a non-standard location (/opt/bitnami/mysql). When you try to install MySQL with the standard Ubuntu tools, it does not detect the BitNami MySQL and then fails trying to run a second MySQL server:

120116  0:09:09 [Note] Plugin 'FEDERATED' is disabled.
120116  0:09:09  InnoDB: Started; log sequence number 0 44233
120116  0:09:09 [ERROR] Can't start server: Bind on TCP/IP port: Address already in use
120116  0:09:09 [ERROR] Do you already have another mysqld server running on port: 3306 ?
120116  0:09:09 [ERROR] Aborting

120116  0:09:09  InnoDB: Starting shutdown...
120116  0:09:10  InnoDB: Shutdown completed; log sequence number 0 44233
120116  0:09:10 [Note] /usr/sbin/mysqld: Shutdown complete

If you need to use a BitNami AMI, you'll need to follow their directions for installing LAMP.

  • This worked... (used the AMI you mentioned) got through LAMP and all installed ok. Now I can't reach my instance from the web, but that's a problem for a different question. Thanks for your help :) – MrVimes Jan 19 '12 at 10:39
  • ... solved. needed to open port 80 on my security group – MrVimes Jan 19 '12 at 10:50

You are using the BitNami Drupal AMI and as Eric mentions it includes MySQL. In fact it includes a LAMP Server installed and Drupal running on top of it. The idea of this AMI is to provide a ready to use Drupal installation in which the user will not need to worry about setting the environment.

In the /opt/bitnami directory you can see that BitNami includes apache, mysql and php folders. It also includes a properties.ini file that includes information about the installed components. The apache configuration file is in /opt/bitnami/apache2/conf/httpd.conf, the php configuration file is in /opt/bitnami/php/etc/php.ini file and the mysql configuration is in /opt/bitnami/mysql/my.cnf. You can use these servers for running other applications on top of it.

If you want to install the system servers the default ports will conflict with BitNami. To avoid this you can execute /etc/init.d/bitnami stop and stop the BitNami servers. If you want to have both running (BitNami and system servers) you will need to configure some of them to use different ports. Apart of that, you should not find any other conflict. BitNami is completely independent from the system components and you can upgrade, install or remove system libraries without breaking the BitNami installation. In the same way, BitNami will not affect your system software (other than the port conflict that I already mentioned.

I'm part of the BitNami team and I thought that adding this clarification will be useful for understanding why you were finding that problem with BitNami.


I also had my installation hang at 79%. In my case I was not using bitnami, just regular apt install mysql-server and the same thing happend with sudo tasksel of LAMP Stack.

In my specific case it turns out my root mysql password had singe quote in it, and that was messing up the mysql configuration step.

I saw this by checking the log I believe it was in /var/log/mysql. In the logs it should half of my password split on the ' character which gave me the idea to try using a different password.

  • This is a very specific case. Was there any clue in the question about this? Also, your answer is still not an answer. Please share how you could manage to solve your problem. – Mostafa Ahangarha Apr 5 '17 at 6:30

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.