I tried to copy an Ubuntu VDI/Virtual Box image to another drive. Now when I boot up I get a black screen with a cursor. If I use host & F1 I can log in via TTY but I can't figure how to boot. I have tried reinstalling guest additions and upgrading, but no dice.

I tried the advice here 12.04.3 can start only after press "resume" in rescue mode (every boot) - problem with Nvidia driver and it still isn't starting but now it flashes different sizes before finalizing at a little black screen with a cursor.

When I try manually running x (sudo startx) it gives me an error of...

error setting MTRR (base = 0xe0000000, size = 0x04200000, type=1) No such device or address (6)

Also after setting no splash etc I now see a console error on boot...

enter image description here

From here I can still boot into the tty but X still won't start

When I run sudo X -configure

enter image description here

I created a 16 version from scratch and it worked fine. Updated to 17 and got the same thing happening again.

  • How did you make the copy, and how was it added and when you say drive - what does that mean? – George Udosen Sep 3 '17 at 11:34
  • I copied the .vdi, etc from one drive to another. I didn't do anything special like package to an appliance. – Jackie Sep 3 '17 at 14:05

My inelegant solution was...

  1. Create another virtual drive attach it as SATA
  2. Startup failing machine and mount via terminal the new vdi
  3. Copy all files to the new drive
  4. Shutdown bad machine
  5. Create new Ubuntu machine
  6. Mount new drive as well as OS drive
  7. Copy files over to New OS drive

There might be a way to just mount the old broken drive as a second drive, but mine was encrypted and I couldn't get it to work.

I will still give bounty to anyone that can get the old one to actually boot.


I don't exactly know what you mean by 'new drive' but creating a new OS from a VirtualBox 'VDI' image of file should be done like this:

  1. Have the 'VDI' file ready in any folder

  2. Create a new OS on Virtualbox device using the usual steps, but when at the 'HARD DISK' step choose the option 'Use an existing virtual disk file':

    enter image description here

  3. Select the 'VDI' from step 2.

  4. Set up the Network and choose the 'Bridged Adapter' option:

    enter image description here

  5. Now start the Virtual VM.

Image(s) courtesy of linuxbsdos

  • I am pretty sure I followed these steps short of the network setting given the information above. I will go ahead and try it out but I feel like this has to be an X issue given the above info and the fact it starts and gets packages. I just can't get anything but tty – Jackie Sep 3 '17 at 14:03
  • Sorry this had no affect, I did notice some more info in the console if that helps. – Jackie Sep 3 '17 at 14:10
  • >Syntax error: Invalid command 'setvdiuuid' – Jackie Sep 3 '17 at 14:20
  • I really think you are barking up the wrong tree I think the graphics card is not passing through the proper permissions – Jackie Sep 3 '17 at 14:20
  • Let me understand you very well you copied a (formerly working VM) and wish to move it to another drive (which I still don't understand what drive means here) but it won't start the display manager? Please correct me if I am wrong in my assumptions! – George Udosen Sep 3 '17 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.