1

I'm running Ubuntu 17.04, "zesty".

I need to install version 8 of Google Protocol Buffer.

I can find the package at https://packages.ubuntu.com/trusty/amd64/libprotobuf8/download

The instructions state that aptitude is the preferred way to download and install the package.

I've added the following line to the end of /etc/apt/sources.list:

deb http://mirrors.kernel.org/ubuntu/pool/main/p/protobuf trusty main 

Then I run aptitude:

$ sudo aptitude install libprotobuf8=libprotobuf8_2.5.0-9ubuntu1_amd64.deb
Unable to find a version "libprotobuf8_2.5.0-9ubuntu1_amd64.deb" for the package "libprotobuf8"
Unable to apply some actions, aborting

$ sudo aptitude install libprotobuf8=2.5.0-9ubuntu1
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

Using apt-get doesn't work either:

$ sudo apt-get install libprotobuf8=2.5.0-9ubuntu1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Can't find a source to download version '2.5.0-9ubuntu1' of 'libprotobuf8:amd64'

When I run sudo apt-get update

I see

...
Err:3 http://mirrors.kernel.org/ubuntu/pool/main/p/protobuf trusty/main amd64 Packages                                
  404  Not Found
...

W: The repository 'http://mirrors.kernel.org/ubuntu/pool/main/p/protobuf trusty Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://mirrors.kernel.org/ubuntu/pool/main/p/protobuf/dists/trusty/main/binary-amd64/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

Nevertheless, /var/lib/dpkg/status shows:

Package: libprotobuf8
Status: install ok config-files
Section: libs
Installed-Size: 1083
Architecture: amd64
Multi-Arch: same
Source: protobuf
Version: 2.5.0-9ubuntu1
Config-Version: 2.5.0-9ubuntu1
Depends: libc6 (>= 2.14), libgcc1 (>= 1:4.1.1), libstdc++6 (>= 4.3), zlib1g (>= 1:1.1.4)
 This package contains the runtime library needed for C++ applications.
Homepage: https://code.google.com/p/protobuf/
Original-Maintainer: Robert S. Edmonds <[email protected]>

However I can't find libprotobuf.so.8 anywhere on the system.

What am I doing wrong?

2
  • Which version of ubuntu are you running?
    – mondjunge
    Aug 31, 2017 at 12:13
  • Ubuntu 17.04, "zesty"
    – empty
    Aug 31, 2017 at 16:20

2 Answers 2

2

Couldn't get to install with suggested answers so downloaded the file from http://mirrors.kernel.org/ubuntu/pool/main/p/protobuf

and

sudo apt install ./libprotobuf8_2.5.0-9ubuntu1_amd64.deb
1
  • since you are running a newer version than this package is build for, this is your best option.
    – mondjunge
    Sep 1, 2017 at 7:32
1
  1. libprotobuf8 is already in ubuntu repos, you could just simply install it with your package manager, apt-get or aptitude. Ex.

    sudo apt-get install libprotobuf8

  2. That source you added is basically useless or not needed, I'd remove it

  3. When specifing a package version just use the version, not the name & certainly not the .deb name. Ex.

    sudo aptitude install libprotobuf8=2.5.0-9ubuntu1

3
  • The apt-get call didn't work but the aptitude call did.
    – empty
    Aug 30, 2017 at 23:49
  • Spoke too soon. "sudo aptitude install libprotobuf8=2.5.0-9ubuntu1" results in "No packages will be installed, upgraded, or removed. 0 packages upgraded, 0 newly installed, 0 to remove and 6 not upgraded. Need to get 0 B of archives. After unpacking 0 B will be used. "
    – empty
    Aug 30, 2017 at 23:59
  • 2
    "libprotobuf8 is already in ubuntu repos" Only in Trusty, which OP is obviously not running.
    – fkraiem
    Aug 31, 2017 at 1:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .