5

I have a Dell XPS 15 (2017) with dual boot (Windows 10 + Ubuntu 16.04). While trying to install the nvidia drivers (in order to be able to disable the nVidia GPU and let it run on onboard graphics for lower power consumption), my system got messed up. Up until some minutes ago, after shutting down or restarting my computer, I got a black screen with the following output:

/dev/nvme0n1p4: recovering journal
/dev/nvme0n1p4: clean, 455620/127927 files, xx/xxx blocks
[xxxx.xxxx] NMI watchdog: BUG: soft lockup - CPU#1 stuck for 23s! [plymouthd:13948]
[xxxx.xxxx] NMI watchdog: BUG: soft lockup - CPU#1 stuck for 23s! [plymouthd:13948]
INFO: rcu_sched self-detected stall on CPU
o1-...: (14999 ticks this GP) idle=4e5/140000000000/softirq=98156/98156 fqs7496
o (t=xxxxxx jiffies g=xxxxxx c=xxxxxx q=xx

Click here to view the complete log (picture)

After following this answer, after step 2, my computer stopped displaying a black screen with the error message above and now only freezes after pressing the shutdown/restart button. Trying sudo swapoff -a && systemctl poweroff has the exact same impact.

I have also tried logging the shutdown procedure with no luck so far (run systemctl start debug-shell and then hit ctrl+alt+F9 when the hang up occurred, but no response at all.

I am currently using the X.org X server drivers (since after trying one nVidia driver I was unable to open my computer). Additionally, even though I have purged all nVidia drivers, the Additional Drivers dialogue still displays a bunch of them (nvidia-384 nvidia-375 nvidia-378 nvidia-381).

I am sorry for the long post-but I tried to supply as much information as possible in order to identify the problem.

5

Eventually, the solution that fixed everything for me was the following (at least for my system configuration):

  • edit /etc/default/grub
  • add acpi_rev_override=1 to your GRUB_CMDLINE_LINUX_DEFAULT parameters

    (in my case the line looks like this):

     GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_rev_override=1"
    
  • run sudo update-grub from the terminal

after shutting down your machine one more time from the power button, the problem should have been fixed.

  • Solved problem also on my XPS 15 9560 with Linux Mint 18.3 Sylvia – pirho Apr 3 '18 at 6:48
  • This doesn't work for me, neither do any of the other posts I've found so far. WTF is going on with Ubuntu? – Stefan May 1 '18 at 9:03
  • 1
    I googled quite a bit and noticed that a lot of the posts mention Nvidia drivers. I switched to the proprietary 384.111 driver via the Software center, this seems to have fixed the problem. Now I can shut down or reboot through the terminal or the GUI power button, none of the other posts on line worked for me. Hope this helps someone. Once you switch to the proprietary Nvidia driver, you need to do a hard reboot (via the power button (the physical one)) for the new driver to start working. – Stefan May 1 '18 at 9:15

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.