10

Recently I have been testing some desktop environments like Budgie and Cinnamon and I noticed that now my Google Chrome omnibox (also know as Address Bar) has a very small font.

I already tried to reset Chrome settings, tried to change the theme and also changed the font-size in the Settings. I even installed Chromium - and the problem is the same.

enter image description here

Anyone know what exactly is responsible for the address bar font size?

6
  • AFAIK, there's no user-accessible method to change the font size in the address bar. What you can try is different fonts in your ~/.config/gtk-3.0/settings.ini. Not all fonts of the same "size" appear visually of the same size. You can find the "largest" one by having the same text in several line in LibO Writer and testing different fonts. You'll see a difference. Choose the one you like. As a user that's about all you can do. The font-size in Chrome's urlbar has been a WontFix for years :(
    – DK Bose
    Aug 30, 2017 at 5:29
  • I'd suggest DejaVu Sans.
    – DK Bose
    Aug 30, 2017 at 5:35
  • 1
    Great, thanks! The problem was really with the font. I was using "Garuda". Now it's working fine. Thanks :)
    – euDennis
    Aug 30, 2017 at 22:47
  • 3
    "The font-size in Chrome's urlbar has been a WontFix for years" -> I'm thinking of switching to a different browser, because that is ridiculus. Feb 5, 2018 at 4:23
  • I already switched for the Firefox, since quantum project it has evolved a lot. Anyway, this is one of the issues that I had with Google Chrome and fonts.
    – euDennis
    Feb 6, 2018 at 9:14

7 Answers 7

3

In Ubuntu 18.04.3 enabling 'Large Text' in Settings->Universal Access enlarges font size in Chrome's and Chromium's address bar for me.

Settings > Universal Access > Large Text

1

The problem was with the font "Garuda", probably some weird bug. Just changing to other font in the system and rebooting fixed.

Thanks!

2
  • 1
    I'm using the Ubuntu 16.04 default font and have the same issue? Feb 5, 2018 at 4:30
  • I'm not sure if I can help you. What Ubuntu and Chrome version are you using? Did you tried to change the font and reboot?
    – euDennis
    Feb 6, 2018 at 9:15
1

A blast from the past! I, too, was messing with system fonts in Ubuntu and ended up with the Chrome address bar stuck at a too-small size and not paying attention to changes in system font size configured in Tweaks. Neither clearing cache, removing/reinstalling google-chrome-stable or deleting the user profile folder fixed it.

What did fix it was restoring the system font to the original (and aptly-named default) font "Ubuntu regular". And you have to exit and restart the browser for the config change to take effect.

I guess Chrome does pick up the name of the system font but ignores the system configured font size when rendering the address bar. Evidence: When I change the system font size in Tweaks then restart Chrome, it is using the new size in tabs, bookmark bar, hover text and others, but not in address bar, application list (9 blocks).

Now, why the one-and-only size is OK for the default system font (Ubuntu) but not for, say Umpush and the few others I happened to try, I cannot say. All of these are True Type fonts, so I do not believe they have any native default size.

Since Chromium is reported to have the same behavior (I have not confirmed), why doesn't some public spirited dev offer a PR to

0

Fonts in address bar of chrome is too small. I found that the system font that you used bigger than default size. Ordinary, the default size 0f fonts is 10. When you use custom fonts. Some fonts are too small when the size is 10. So, you increase the size of the font to be 15+. Now, you can see suitable custom fonts on desktop. But fonts in address bar of chrome are too small. I think that there are default size of font for use everywhere in chrome. Maybe, in address bar the size of fonts are 8. So. You will see this font between 15+ and 8. I fix this by select fonts that look suitable when size is 10. Try it. Maybe help.

0

Quick fix:
after so many bashing my head to wall - in Tweak Tool - just reset the fonts, and restart Chrome-Browser.

Or, instead of Garuda - set any other font - and restart Chrome-Browser.

0

i have no programming knowledge, and a newbie. pls bear with me if i do not use the terms correctly as i share my experience.

i created a text file and in it i entered the following: "google-chrome-stable --force-device-scale-factor=1.8" and saved the file to desktop. I right click the file and select "Properties"->"General" and under "Open with:" select "Terminal Emulator" and under "Permissions" i tick "allow this to run as a program".

when i double clicked the file, chrome browser opened with larger fonts including omnibar.

1
  • In the comments of the question you will see it has already been fixed by the OP. Do not see how this 5 year later answer will help.
    – David
    Apr 1, 2023 at 8:29
0

I had the same issue but was already using "Ubuntu regular" - but i was using it at 18pt instead of the default 10pt. Going into tweak tool and setting it back to the default 10pt size and then setting the "scaling factor" option to be 1.8 now keeps my system fonts the same size as before, and now my omnibar font matches the rest of my system.

Any custom font sizes i set in any other application now needs to be reconfigured. I wish chrome would not have hardcoded a 10pt font size in such an important place.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .