0

I have a weird problem with internet connection. I connect to wifi with my PC and all seems right until something invisible happens (while idle or while doing something, it seems random) and everything becomes unreachable. Computers in the same network or local hosts, all become immediately unreachable (I have observed this while controlling an online action game through synergy). No applet reports any problems. When this happens, trying to ping something results in a long waiting time and a reply that destination host unavailable.

I tried to make it forget the network and set it up again, but to no avail. I tried to replace network-manager with wicd, but it happened again (this leaves me worried that even reinstalling Ubuntu might not fix it). It does not appear to happen on Windows, but I might have been simply using it too little (and I do not wish to switch to Windows).

Disconnecting and connecting again fixes the problem temporarily, but it is very annoying because I am controlling the PC via synergy.

I have searched some logs and it seems to appear together with a message about switching bandwidth. I am not certain if it really correlates with the error or if it is relevant.

According to lspci, the card is Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32). I am using Ubuntu 16.04 64-bit.

  • Any news on this topic @dugi? – user886869 Jan 15 '18 at 16:16
  • No. I replaced network manager by wicd and it worked for some time. Then I tried connect using the dhclient command for some time, but it only allows me to fix it fast when it happens. Now I installed network manager back, removing wicd and it seems to work. No idea for how long it will work. Some useful stuff might be here: askubuntu.com/questions/54710/… – Dugi Jan 16 '18 at 16:45
  • Maybe you are suffering from a bug in the ath10k firmware on newer kernels (Superior to 4.11 I think). Give a look on the bug report, and this forum post, they have some fixes bugs.launchpad.net/ubuntu/+source/linux-firmware/+bug/1743279 and ubuntuforums.org/…. It was exactly my problem and it helped me to resolve it. – user886869 Jan 17 '18 at 15:42
  • @user886869 I did it, I will report back when I am sure that it helped. – Dugi Jan 18 '18 at 16:21
  • @user886869 It didn't help. I have found a script that checks if the router is accessible and restarts the network if it is not, so I am trying how will that work. – Dugi Jan 30 '18 at 21:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.