[Update] I'm able to install the 375 drivers fine using

sudo apt-get install nvidia-375

but the issue below still persists with 381.[/Update]

So last night I decided to update my nvidia drivers to 381 following some steps I found online. Here are the steps I followed:

sudo apt-get purge nvidia*
sudo add-apt-repository ppa:graphics-drivers
sudo apt-get update
sudo apt-get install nvidia-381

Whenever I get to "sudo apt-get install nvidia-381" command I receive "Unable to locate package nvidia-381"

I've searched everywhere and can't find a solution this. Any ideas?

Here is my output:

tyler@tyler-ubuntu:~$ sudo add-apt-repository ppa:graphics-drivers/ppa
 Fresh drivers from upstream, currently shipping Nvidia.

## Current Status

Current official release: `nvidia-381` (381.22)
Current long-lived branch release: `nvidia-375` (375.66)

For G8x, G9x and GT2xx GPUs use `nvidia-340` (340.102)
For NV4x and G7x GPUs use `nvidia-304` (304.135)

Support timeframes for Unix legacy GPU releases:

## What we're working on right now:

- Normal driver updates
- Help Wanted: Mesa Updates for Intel/AMD users, ping us if you want to help do this work, we're shorthanded.


This PPA is currently in testing, you should be experienced with packaging before you dive in here:

Volunteers welcome! See also: https://github.com/mamarley/nvidia-graphics-drivers/

### How you can help:

## Install PTS and benchmark your gear:

    sudo apt-get install phoronix-test-suite

Run the benchmark:

    phoronix-test-suite default-benchmark openarena xonotic tesseract gputest unigine-valley

and then say yes when it asks you to submit your results to openbechmarking.org. Then grab a cup of coffee, it takes a bit for the benchmarks to run. Depending on the version of Ubuntu you're using it might preferable for you to grabs PTS from upstream directly: http://www.phoronix-test-suite.com/?k=downloads

## Share your results with the community:

Post a link to your results (or any other feedback to): https://launchpad.net/~graphics-drivers-testers

Remember to rerun and resubmit the benchmarks after driver upgrades, this will allow us to gather a bunch of data on performance that we can share with everybody.

If you run into old documentation referring to other PPAs, you can help us by consolidating references to this PPA.

If someone wants to go ahead and start prototyping on `software-properties-gtk` on what the GUI should look like, please start hacking!

## Help us Help You!

We use the donation funds to get the developers hardware to test and upload these drivers, please consider donating to the "community" slider on the donation page if you're loving this PPA:

 More info: https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keybox '/tmp/tmpf35j9cfi/pubring.gpg' created
gpg: /tmp/tmpf35j9cfi/trustdb.gpg: trustdb created
gpg: key FCAE110B1118213C: public key "Launchpad PPA for Graphics Drivers Team" imported
gpg: Total number processed: 1
gpg:               imported: 1
tyler@tyler-ubuntu:~$ sudo apt-get update
Hit:1 http://repo.steampowered.com/steam precise InRelease
Ign:2 http://dl.google.com/linux/chrome/deb stable InRelease                   
Hit:3 http://packages.microsoft.com/repos/vscode stable InRelease              
Hit:4 http://us.archive.ubuntu.com/ubuntu zesty InRelease                      
Hit:5 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu zesty InRelease     
Hit:6 http://dl.google.com/linux/chrome/deb stable Release                     
Get:7 http://security.ubuntu.com/ubuntu zesty-security InRelease [89.2 kB]     
Hit:8 http://us.archive.ubuntu.com/ubuntu zesty-updates InRelease              
Get:9 http://us.archive.ubuntu.com/ubuntu zesty-backports InRelease [89.2 kB]  
Hit:10 http://ppa.launchpad.net/noobslab/macbuntu/ubuntu zesty InRelease       
Hit:11 http://ppa.launchpad.net/xorg-edgers/ppa/ubuntu zesty InRelease         
Fetched 178 kB in 0s (204 kB/s)                                                
Reading package lists... Done
tyler@tyler-ubuntu:~$ sudo apt-get install nvidia-381
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package nvidia-381

Additional outputs:

tyler@tyler-ubuntu:~$ cat /etc/lsb-release
tyler@tyler-ubuntu:~$ apt-cache policy nvidia-381
N: Unable to locate package nvidia-381
  • Remove the xorg edgers ppa, it could conflict? Just a guess – Mark Kirby Aug 29 '17 at 19:01
  • @MarkKirby I don't think they conflict. Anyway the package should be found. – Pilot6 Aug 29 '17 at 19:04
  • What about other packages? Can you install anything else? – Pilot6 Aug 29 '17 at 20:33
  • Yes, I just installed kdenlive to test and it installed fine. – Tyler Brady Aug 29 '17 at 20:45

Because this is a top listed return search on Google on the subject, I wanted to post this because it seems things have changed.

This won't work for me after a fresh Ubuntu Desktop 18.0.4 install:

sudo apt install nvidia-396

This will:

sudo apt install nvidia-driver-396

No idea why the syntax changed. Makes for a lot of information on installing Nvidia drivers on the web confusing. So much wasted time!

  • 3
    This is what finally worked for me after hours of trying to follow conflicting, incorrect, or incomplete information on other pages (I used 410, not 396). – Grant Petty Nov 12 '18 at 19:10
  • This is what I got now.. Unable to locate package nvidia-driver-396 – zwep Dec 17 '18 at 17:16
  • @zwep You may have already fixed this, but if not, try sudo apt install nvidia-396 instead of sudo apt install nvidia-driver-396. – dearN Jan 9 at 13:35
  • 2
    This worked for me with nvidia-driver-418. – Boris Mar 29 at 5:56

Problem solved.

When verifying my PPA's in Software & Updates > Other Software I noticed that the graphics-drivers PPA was listed SEVERAL times in the PPA list. I removed all of the PPA's related to graphics-drivers and started the install over from scratch and it finally located and installed the nvidia-381 drivers.

I'm not sure why the repository was listed so many times but none-the-less after removing and going through the install again it finally worked.

  • thanks , had same problem [also do not know why had many similar reps...] – S12000 Jul 10 at 21:36

The second command is wrong. It should be:

sudo add-apt-repository ppa:graphics-drivers/ppa
  • 1
    I'm still receiving "Unable to location package nvidia-381" after making this change. – Tyler Brady Aug 29 '17 at 18:53
  • Do you read what the terminal outputs? Are there any error messages? I suggest posting the output of the 2nd and 3rd command TO YOUR QUESTION. – Pilot6 Aug 29 '17 at 18:55
  • No error message from what I can see. I've added the output to the original post. – Tyler Brady Aug 29 '17 at 19:00
  • 1
    doesn't work. I'm still getting the error. – Aaron Jan 18 '18 at 0:28

sudo apt install nvidia-396

For GeForce 8 and 9 series GPUs use nvidia-340

For GeForce 6 and 7 series GPUs use nvidia-304


If you look at the ppa, the package is called "nvidia-graphics-drivers-381"


sudo apt-get install nvidia-graphics-drivers-381
  • 1
    nvidia-381 is there if you look more careful. I checked and it installs for me. – Pilot6 Aug 29 '17 at 19:12
  • @Pilot6 linky ? – Panther Aug 29 '17 at 20:22
  • And there is no nvidia-graphics-drivers-381 deb. So the command is wrong. Downvote. – Pilot6 Aug 29 '17 at 20:25
  • Look into the package details and you will see. It is a bit confusing. – Pilot6 Aug 29 '17 at 20:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.