3

I am running Ubuntu 16.04 on a HP Pavilion Laptop 15-AW004NA. It ran initially for a couple of weeks fine, but now only boots to initramfs. I have re-installed Ubuntu a few times, it will typically work once or twice. Then crash whilst doing a normal operation such as web browsing. After which it wont boot past initramfs.

I have tried: -

manually running the fsck (with -y command it cycles through thousands of commands and CPU hikes up) re-installing Ubuntu 16.04 (encrypted and non-encrypted discs) installing Ubuntu 16.04 then upgrading to 17.10 installing Lubuntu 16.04

I have checked the hard drive using Smart Data and Self Tests, results looked fine.

Live boot works fine with Ubuntu and Lubuntu.

Any ideas how i can debug further???

Cheers Lizard

XXXX@Lizard-Laptop:~$ grep -i sda /var/log/syslog*
/var/log/syslog:Aug 31 19:12:21 Lizard-Laptop systemd[1]: Starting Cryptography Setup for sda3_crypt...
/var/log/syslog:Aug 31 19:12:21 Lizard-Laptop systemd-cryptsetup[746]: Volume sda3_crypt already active.
/var/log/syslog:Aug 31 19:12:21 Lizard-Laptop systemd[1]: Started Cryptography Setup for sda3_crypt.
/var/log/syslog:Aug 31 19:12:21 Lizard-Laptop systemd[1]: Found device /dev/mapper/sda3_crypt.
/var/log/syslog:Aug 31 19:12:21 Lizard-Laptop systemd-fsck[751]: /dev/sda2: clean, 299/124928 files, 144327/499712 blocks
/var/log/syslog:Aug 31 19:12:21 Lizard-Laptop systemd-fsck[750]: /dev/sda1: 8 files, 870/130812 clusters
/var/log/syslog:Aug 31 19:12:21 Lizard-Laptop kernel: [    4.323111] sd 0:0:0:0: [sda] 1953525168 512-byte logical blocks: (1.00 TB/932 GiB)
/var/log/syslog:Aug 31 19:12:21 Lizard-Laptop kernel: [    4.323113] sd 0:0:0:0: [sda] 4096-byte physical blocks
/var/log/syslog:Aug 31 19:12:21 Lizard-Laptop kernel: [    4.323123] sd 0:0:0:0: [sda] Write Protect is off
/var/log/syslog:Aug 31 19:12:21 Lizard-Laptop kernel: [    4.323125] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
/var/log/syslog:Aug 31 19:12:21 Lizard-Laptop kernel: [    4.323140] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
/var/log/syslog:Aug 31 19:12:21 Lizard-Laptop kernel: [    4.429742]  sda: sda1 sda2 sda3
/var/log/syslog:Aug 31 19:12:21 Lizard-Laptop kernel: [    4.430076] sd 0:0:0:0: [sda] Attached SCSI disk
/var/log/syslog:Aug 31 19:12:21 Lizard-Laptop kernel: [   35.639691] EXT4-fs (sda2): mounting ext2 file system using the ext4 subsystem
/var/log/syslog:Aug 31 19:12:21 Lizard-Laptop kernel: [   35.778035] EXT4-fs (sda2): mounted filesystem without journal. Opts: (null)
XXXX@Lizard-Laptop:~$ 
XXXX@Lizard-Laptop:~$ ls -alt /var/crash
total 8
drwxr-xr-x 13 root root     4096 Feb 15  2017 ..
drwxrwsrwt  2 root whoopsie 4096 Feb 15  2017 .
  • Do you dual-boot with Windows? Do you have a SSD? If so, what make/model? – heynnema Aug 29 '17 at 20:53
  • Nope just Ubuntu on the hard drive and no its not solid state. Model is WDC WD10JPVX-60JC3T0. Cheers – Lizard88 Aug 30 '17 at 17:00
  • Let's run a manual fsck once more. See my brief answer, below. If it outputs more than the normal pass 1, pass 2, etc... then copy/paste that info into your original question, ping me at @heynnema, and I'll take a look for you. ps: also do grep -i sda /var/log/syslog* and ls -alt /var/crash and copy/paste that into your question also. – heynnema Aug 30 '17 at 17:13
3

To check the file system on your Ubuntu partition...

  • boot to the GRUB menu
  • choose Advanced Options
  • choose Recovery mode
  • choose Root access
  • at the # prompt, type sudo fsck -f /
  • repeat the fsck command if there were errors
  • type reboot

If for some reason you can't do the above...

  • boot to a Ubuntu Live DVD/USB
  • start gparted and determine which /dev/sdaX is your Ubuntu EXT4 partition
  • quit gparted
  • open a terminal window
  • type sudo fsck -f /dev/sdaX # replacing X with the number you found earlier
  • repeat the fsck command if there were errors
  • type reboot
  • Thanks for your help. The second option seems to have worked. Its been rebooted a few times and seems stable. I have also pasted the requested logs above. – Lizard88 Aug 31 '17 at 18:32
  • @Lizard88 the logs look fine. Do you dual-boot with Windows? – heynnema Aug 31 '17 at 19:07
  • No its just Linux. Swiped Windows the day i got the laptop :-) Ive installed a fresh copy of Ubuntu will see how that goes. – Lizard88 Sep 1 '17 at 20:02
  • (would love explicit instructions on booting to grub menu) – Amanda Jun 4 '18 at 0:51
  • 1
    If you don't see the GRUB menu at boot time, you can hold down the SHIFT key at boot time to show it. – heynnema Jun 4 '18 at 13:47

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.