1

I'm very new to ubuntu and everything has been going smoothly until I moved into my dorm. I can connect to the wifi just fine but it randomly freezes up. When I click the connection to reset it, it disconnects and reconnects then works for another 5 minutes. Any help would be appreciated cause I am a computer science major and need my laptop working! EDIT when I enter lspci -knn | grep Net -A3

02:00.0 Network controller [0280]: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe [1814:3290]
    Subsystem: Hewlett-Packard Company Ralink RT3290LE 802.11bgn 1x1 Wi-Fi and Bluetooth 4.0 Combo Adapter [103c:18ec]
    Kernel driver in use: rt2800pci
    Kernel modules: rt2800pci
6
  • Check this: askubuntu.com/questions/529347/… and this article: itsfoss.com/speed-up-slow-wifi-connection-ubuntu
    – pomsky
    Aug 29, 2017 at 15:37
  • 1
    Please edit your question and add output of lspci -knn | grep Net -A3 terminal command.
    – Pilot6
    Aug 29, 2017 at 16:06
  • Does the issue appear only with the dorm network or are other wireless networks affected too? Aug 29, 2017 at 17:40
  • David Foerster, it workd fine on other wifi networks just not my schools. I get an error on the page saying "SSL_ERROR_CERT_DOMAIN"
    – Jacob
    Aug 29, 2017 at 18:09
  • Please don't add "Solved" to the title. Instead, accept an existing answer by clicking on its checkmark.
    – edwinksl
    Aug 31, 2017 at 1:01

2 Answers 2

1

I know at least two universities I've worked for have issued their own certs to some part of the network infrastructure... I suspect mostly in order to intercept SSL traffic. The SSL error you reference in your comments makes me think that's the issue.

At those institutions, in order to be connect to the network, one would need to install their CA as a trusted CA on the system in order to make that connection. See this answer for how to do so on the system level. I would recommend consulting your university's IT department website, or contacting the help desk if your school has one.

2
  • This helps a lot! I will show it to the it department.
    – Jacob
    Aug 29, 2017 at 18:58
  • "I would recommend consulting your university's IT department website, or contacting the help desk if your school has one." +1
    – user4815
    Aug 29, 2017 at 18:59
0

This could be due to overcrowding on the router. I've encountered the same issue in a dorm that was later resolved by the dorm upgrading it's wifi routers. The network guys said it was due to the access points being overworked due to radio interference from the large number of devices, which then led to overheating, which led to extremely poor router performance. After they upgraded the routers I never had a problem. I'm not sure that your situation is the same, but, it sounds similar.

1
  • Thank you for replying! I'm getting an error on the internet that says "SSL_ERROR_CERT_DOMAIN"
    – Jacob
    Aug 29, 2017 at 17:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .