0

I have been attempting delete Windows 10 and clean install Ubuntu 16.04.3 LTS on my Samsung R730 laptop.

While the installer ran without an issue, when booting from hard drive the only response was a flashing underscore. The hard drive was detected, but could not be booted.

I ran boot-repair from the Ubuntu trial. The paste is available here. When booting this leads to a new error:

Failed to open \EFI\BOOT\grubx64.efi – Not Found
Failed to load image \EFI\BOOT\grubx64.efi: Not Found
start_image() returned Not Found

I have noticed the boot-repair paste states that “No boot loader is installed in the MBR of /dev/sda”. This answer indicates that I can ignore this.

More prominently \EFI\BOOT\grubx64.efi is not in the list of boot files for the hard disk (SDA). directory, however it is present in the installation USB. In fact the hard drive doesn't have an \EFI directory at all. To my knowledge I can’t simply copy this directory over, however I might be wrong.

What can I do to install the \EFI\BOOT\grubx64.efi image?

  • Do you mean you deleted win10 and made a clean install of Ubuntu? – Redbob Aug 29 '17 at 14:48
  • Yes, that's exactly right. I'll clarify in my question. – user730383 Aug 29 '17 at 14:51
  • 1
    Start by disabling Secure Boot and making sure "Ubuntu" is the first priority in UEFI boot settings. If you can't find try making it boot from a EFI file. PS - You have the EFI partition as expected in a UEFI installation. – user692175 Aug 29 '17 at 14:53
  • I've checked through the BIOS and not found a secure boot option, so I'm not sure if that is installed. The BIOS boot order uses different disks rather than OS's to boot from, I take it the UEFI is something else? – user730383 Aug 29 '17 at 15:00
  • If you do not have the ESP - efi system partition (FAT32), you must have installed in BIOS boot mode to newer UEFI hardware. While that may work, you have to change UEFI to legacy/CSM/BIOS boot mode. Usually better to use UEFI, but that also requires gpt partitioning not the 35 year old MBR(msdos) partitioning. You may not have "Secure boot", but it may say "Windows" or "Other" which is really the secure boot setting. – oldfred Aug 29 '17 at 16:04
0

Good news, I've resolved this issue thanks to MichaelBay.

The problem was with the UEFI system setup on my computer. I used a recovery USB of rEFInd and managed to boot into the installation with no problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.