0

I ran the following command to update my ubuntu machine: sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade --fix-missing -y

upgrade result

After installing updates, it still shows the following when I log in:

shown after login

Can I remove this somehow?

  • Run sudo apt full-upgrade. – Pilot6 Aug 29 '17 at 14:01
  • Doesn't solve this issue. – vespino Aug 29 '17 at 14:08
  • What does this mean? Did anything upgrade? And please don't post terminal output as a screenshot. Post it as text. – Pilot6 Aug 29 '17 at 14:09
  • Sorry, no it didn't do anything. Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. – vespino Aug 29 '17 at 14:10
  • This must be a minor bug, just ignore it. – Pilot6 Aug 29 '17 at 14:11
-1

cd /etc/update-motd.d

90-updates-available is a script containing a link to a file containing the message. I deleted the file: /var/lib/update-notifier/updates-available. This solved my problem.

  • 1
    No, you broke your system. – heynnema Aug 29 '17 at 14:33
  • I did? Tell me how I should have solved it then, please. – vespino Aug 29 '17 at 14:38
  • You deleted a file without knowing what part it plays in the software update system. You probably broke the whole update system (try and run Software Updater and see if it works). If you don't know what it does, you shouldn't touch/delete it. You could try using Synaptic to install the missing updates. – heynnema Aug 29 '17 at 14:42
  • sudo apt-get update && sudo apt-get upgrade runs fine at the moment. – vespino Aug 29 '17 at 14:47

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.