4

I have restarted my computer after an update, then I have noticed that the wifi signal was very weak. I have decided to download this package https://github.com/lwfinger/rtlwifi_new and reinstall the wifi driver but I have the following error: modprobe: ERROR: could not insert 'rtl8723be': Exec format error

I run the following in the package downloaded:

make
sudo make install
modinfo -p rtl8723be

I have following result :

swenc:Set to 1 for software crypto (default 0)
 (bool)
ips:Set to 0 to not use link power save (default 1)
 (bool)
swlps:Set to 1 to use SW control power save (default 0)
 (bool)
fwlps:Set to 1 to use FW control power save (default 1)
 (bool)
msi:Set to 1 to use MSI interrupts mode (default 0)
 (bool)
debug:Set debug level (0-5) (default 0) (int)
disable_watchdog:Set to 1 to disable the watchdog (default 0)
 (bool)
ant_sel:Set to 1 or 2 to force antenna number (default 0)
 (int)

.

sudo modprobe -r rtl8723be

sudo modprobe rtl8723be ant_sel=1

I have following result :

modprobe: ERROR: could not insert 'rtl8723be': Exec format error

I have tried to restart the adapter with the following command:

sudo service networking restart

I'm using ubuntu 17.04 | 4.10.0-33-generic

5
  • You don't need to install anything for 17.04. Uninstall the custom module.
    – Pilot6
    Aug 29, 2017 at 9:48
  • @Pilot6 , If I run the following command sudo apt-get install --reinstall rtlwifi_new-master linux-firmware in the folder of the downloaded package , I have this error : E: Unable to locate package rtlwifi_new-master
    – Sirius
    Aug 29, 2017 at 9:57
  • This command could not output anything else. There is no rtlwifi_new-master package. You need to uninstall what you installed from git. You need to run sudo make uninstall from the directory with the source.
    – Pilot6
    Aug 29, 2017 at 10:05
  • @Pilot6, I just uninstall the package , but my wifi adapter still not detected .
    – Sirius
    Aug 29, 2017 at 10:43
  • 2
    @Pilot6, I fix my issue by following the step in this answer: rlt8723be. Thank so much for your help :)
    – Sirius
    Aug 29, 2017 at 11:12

4 Answers 4

2

I had the same problem, i used to run make, install, mod....etc commands from the same old directory "rtlwifi_new"(which i downloaded a month ago) .

Try a fresh installation by downloading all files again.

1

if you have rtlwifi_new downloaded,

cd rtlwifi_new
sudo make uninstall
sudo make clean

Then, make, install and insert the module. Don't re-download the repo.

1

Same as @Pilot6 (thanks!!!), I fixed my issue with: Wifi problems with rtl8723be in Ubuntu 14.04

After every kernel update:

  1. Execute

     cd rtlwifi_new
    
  2. Clean previous builds with

     make clean
    
  3. Update git repository with

     git pull
    
  4. Compile it with

     make clean && make
    
  5. And install with

     sudo make install
    
  6. Reboot or unload/load modules.

0

Navigate to the modprobe.d folder in root>>etc using terminal and remove the rtl8723de.conf if it exists.Use

sudo rm rtl8723de.conf

It worked for me, try a fresh installation of the wifi driver. You can clone the repository again and start again if you face problem in installation.

Not the answer you're looking for? Browse other questions tagged or ask your own question.