This is the first error message

This is the second one

I have tried quite i few things please help.

If i try this method What I did:

sudo apt-get install linux-headers-uname -r

Reconfigure dkms and load module:

sudo dpkg-reconfigure virtualbox-dkms 
sudo modprobe vboxdrv 

Then VirtualBox works. No computer reboot needed.

I then get:

Active: failed (Result: exit-code) since Tue 2017-08-29 01:16:18 MDT; 7ms ago Docs: man:systemd-sysv-generator(8) Process: 9366
ExecStart=/etc/init.d/virtualbox start (code=exited, status=1/FAILURE)

Aug 29 01:16:18 ubuntu systemd1: Starting LSB: VirtualBox Linux kernel module... 
Aug 29 01:16:18 ubuntu virtualbox[9366]: * Loading VirtualBox kernel modules... 
Aug 29 01:16:18 ubuntu virtualbox[9366]: * modprobe vboxdrv failed. Please use 'd...hy 
Aug 29 01:16:18 ubuntu virtualbox[9366]: ...fail! 
Aug 29 01:16:18 ubuntu systemd1: virtualbox.service: Control process exited, co...s=1 
Aug 29 01:16:18 ubuntu systemd1: Failed to start LSB: VirtualBox Linux kernel module.

Errors, please help

marked as duplicate by karel, Pilot6, David Foerster, Charles Green, Eric Carvalho Aug 29 '17 at 13:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • I tried that, when i try to sudo dpkg-reconfigure virtualbox-dkms i get a , "Failed to start LSB: VirtualBox Linux kernel module " error. – K.. Aug 29 '17 at 7:19
  • 1
    See askubuntu.com/questions/760671/… or disable secure boot. – Takkat Aug 29 '17 at 7:29
  • I actually just figured it out i had to boot into my BIOS and turn of secure boot, apparently i cant have it on with virtualbox? Does anyone know why and if there is a way to make it work with secure boot on? If i reinstall the headers and turn uefi boot then secure boot will it work? Dont expect a answer but thanks for the resources. – K.. Aug 29 '17 at 7:36
  • @K.. The link above explains it completely. If you're asking "does anybody know..." you haven't read it. Please read and understand that no, reinstalling the headers have nothing to do with it. – user692175 Aug 29 '17 at 7:42
  • Yeah I didn't read it because I solved it and got carried away, I'll read it now. Thanks – K.. Aug 29 '17 at 7:50