I'm trying to install haskell on ubuntu 11.10 and I'm following the instructions on this website: https://gist.github.com/1524859

But when I type ./configure I get an error message saying:

checking for path to top of build tree... utils/ghc-pwd/dist/build/tmp/ghc-pwd: error while loading shared libraries: libgmp.so.3: cannot open shared object file: No such file or directory
configure: error: cannot determine current directory

Anyone know what I'm doing wrong?

  • 1
    Make sure to install the dependencies first, libgmp seems to be among them. sudo apt-get install libgmp3-dev freeglut3 freeglut3-dev – mikewhatever Jan 13 '12 at 5:25
  • Okay I tried that and it's telling me the it is already the newest version. So I tried ./configure again and still the same error. Any more suggestions? – Tasha D Jan 17 '12 at 23:26
  • 1
    I'm on 12.04 but where the current libgmp is libgmp.so.10, maybe the same as 11.10. Have you tried installing ghc & seeing if it suitable for your needs? – doug Jan 18 '12 at 0:38
  • 1
    Okay fixed it with sudo ln -s /usr/lib/libgmp.so.10.0.1 /usr/lib/libgmp.so.3 – Tasha D Jan 18 '12 at 0:46
  • 1
    @TashaD: Providing the solution in the comment is nice, but even nicer is a self-answer (look it up on meta), to document for others, that there is an answer to the question, and mark it (√) as accepted answer, which signals, the problem is solved. Of course, now that Jorge wrote the answer, just accept it. – user unknown Feb 4 '12 at 3:30

I was able to solve this by just installing the right packages (no linking).

sudo apt-get install libgmp3c2 freeglut3 freeglut3-dev -y

I'll note that I already had these dependencies installed:

make libssl-dev build-essential curl git-core
  • 1
    It was the libgmp3c2 package that solved the issue for me. – David Medinets Apr 16 '14 at 14:19

Op fixed this with:

sudo ln -s /usr/lib/libgmp.so.10.0.1 /usr/lib/libgmp.so.3

This worked for me (Ubuntu 13.04 x86_64) with the slight change

sudo ln -s /usr/lib/x86_64-linux-gnu/libgmp.so.10.0.5 /usr/lib/libgmp.so.3

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.