0

I have a USB-AC56 Wireless-AC1300 wireless adapter and kernel version 4.4.0-92-generic on a standard ubuntu 16.04 installation.

I downloaded version 4.3.1.4 of the driver from the official asus site. The installation process involves unpacking and compiling the driver source code using make. When I do that I get:

In file included from /home/han/downloads/RTL8812AU_linux_v4.3.13_14061.20150505/driver/rtl8812AU_linux_v4.3.13_14061.20150505/include/drv_types.h:95:0,
                 from /home/han/downloads/RTL8812AU_linux_v4.3.13_14061.20150505/driver/rtl8812AU_linux_v4.3.13_14061.20150505/core/rtw_cmd.c:22:
/home/han/downloads/RTL8812AU_linux_v4.3.13_14061.20150505/driver/rtl8812AU_linux_v4.3.13_14061.20150505/include/hal_com.h:412:13: error: ‘file_path’ redeclared as different kind of symbol
 extern char file_path[PATH_LENGTH_MAX];
             ^
In file included from include/linux/seq_file.h:10:0,
                 from include/linux/pinctrl/consumer.h:17,
                 from include/linux/pinctrl/devinfo.h:21,
                 from include/linux/device.h:24,
                 from include/linux/dmaengine.h:20,
                 from include/linux/netdevice.h:38,
                 from /home/han/downloads/RTL8812AU_linux_v4.3.13_14061.20150505/driver/rtl8812AU_linux_v4.3.13_14061.20150505/include/osdep_service_linux.h:35,
                 from /home/han/downloads/RTL8812AU_linux_v4.3.13_14061.20150505/driver/rtl8812AU_linux_v4.3.13_14061.20150505/include/osdep_service.h:41,
                 from /home/han/downloads/RTL8812AU_linux_v4.3.13_14061.20150505/driver/rtl8812AU_linux_v4.3.13_14061.20150505/include/drv_types.h:32,
                 from /home/han/downloads/RTL8812AU_linux_v4.3.13_14061.20150505/driver/rtl8812AU_linux_v4.3.13_14061.20150505/core/rtw_cmd.c:22:
include/linux/fs.h:2610:14: note: previous declaration of ‘file_path’ was here
 extern char *file_path(struct file *, char *, int);
              ^
scripts/Makefile.build:258: recipe for target '/home/han/downloads/RTL8812AU_linux_v4.3.13_14061.20150505/driver/rtl8812AU_linux_v4.3.13_14061.20150505/core/rtw_cmd.o' failed

I have also tried using chili555's answer which uses open source drivers but they don't seem to work for the newer kernel versions giving an error like:

Module 8812au not found in directory /lib/modules/4.10.0-28-generic

I found people hit similar compilation problems here with a TP-link wifi adapter and they suggest that the driver is not supported for newer kernels and use some rtl8192cu-fixes. On their github page they say:

As a rule of thumb, this driver generally works with devices that use the RTL8192CU chipset, and some devices that use the RTL8188CUS, RTL8188CE-VAU and RTL8188RU chipsets too, though it's more hit and miss.

My device is an RTL8812au chipset though.

Any help much appreciated! Thanks!

1

Thanks to chili555 for the comment - using the https://github.com/jeremyb31/rtl8812AU.git repo seems to have worked.

Instead of pulling the repo with git I just downloaded a zip from master at 1965843f9096ccb7f16ed065f6d9cc3885cc31c1, unpacked it then did:

sudo apt-get install dkms
sudo dkms add ./rtl8812AU
sudo dkms install rtl8812AU/5

and restarted and the device appeared in the list of connection options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.