1

I am trying to run an app and I am getting this error in a fresh installation of Ubuntu in VMWARE

./futurerestore_linux: error while loading shared libraries: libzip.so.2: cannot open shared object file: No such file or directory

I had an similar error earlier today and looks like I had to create a link.

However I do see libzip.so.2 in /lib/x86_64-linux-gnu when I did dir in this directory, so unsure what I need to do to get this working. Interesting part is, I don't see it as a package

1

You have to install libzip.

Maybe try the command:

sudo apt install libzip4

Also I had to install libcurl to get the program to work.

sudo apt install libcurl3

0

First try running ldconfig command to recreate links e and libraries cache. As you said that file already exists may you need only a refresh.

$ sudo ldconfig
$ ./futurerestore_linux ...

If this not work you could use ldd command to list all shared libraries of this program.

$ ldd futurerestore_linux

check where libzip.so.2 appears, note also the common path for others libraries. In my case was something like:

libzip.so.2 => not found
libssl.so.1.0.0 => /lib/x86_64-linux-gnu/libssl.so.1.0.0 (0x00007fbaf8313000) ...

So I tried find libzip.so.4 with

$ ls -la /usr/lib/x86_64-linux-gnu/libzip*.*

there was libzip.so.4 and libzip.so but no signal of version 2. so I tried creating a link and its worked.

$ sudo ln -s libzip.so /usr/lib/x86_64-linux-gnu/libzip.so.2
$ sudo ldconfig

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.