0

This question already has an answer here:

I have recently installed Ubuntu 16.04 on my Dell Inspiron 15 7559.

Specs:

  • Intel® Core™ i7-6700HQ CPU @ 2.60GHz × 8
  • 1TB drive
  • 16GB memory
  • NVidia Geforce GTX 960M

Everything works apart from my nvidia card. I have tried installing many versions which all led to low graphics mode error. I recently tried the v384 driver and my system booted up normally and I thought I'd succeeded, but I was wrong. My Additional Drivers page shows that I have nvidia 384 selected but nvidia x server is empty and system info still shows that I'm running Intel Skylake.

How can I fix this?

marked as duplicate by David Foerster, Zanna, Yaron, Eric Carvalho, edwinksl Aug 31 '17 at 19:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Is there anything in the UEFI settings (BIOS) for selecting which video hardware to use? – ubfan1 Aug 29 '17 at 0:07
  • Ill take a look – MGorin247 Aug 29 '17 at 0:09
  • there is nothing in UEFI setting for selecting video hardware – MGorin247 Aug 29 '17 at 0:17
  • i have restricted repo enabled :( – MGorin247 Aug 29 '17 at 0:36
  • anyone can help? – MGorin247 Aug 29 '17 at 1:59
-1

I have finally found the answer on my own.

For those that are experiencing the same issues, you have to install bumblebee for optimus support. I used the instructions in this YouTube video, and it worked for me.

sudo apt-add-repository ppa:graphics-drivers
sudo apt-add-repository bumblebee/testing
sudo apt-add-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install nvidia-367 # or install the newest version if there is a newer one
sudo bumblebee-nvidia bbswitch-dkms prime-indicator
sudo prime-select intel
sudo reboot

Not the answer you're looking for? Browse other questions tagged or ask your own question.