0

Situation after installing Ubuntu 16.04LTS on a "/" partition using as home a preexisting "/home/" partition from a previous Ubuntu 12.04 where everything was running fine (nvidia, realtek SD card reader, wireless, DVD, etc) everything...

Now, with 16.04, wireless is not working anymore

Laptop: Sony Vaio VPCF23JFX.

user@vaio:~$ lshw
...
*-pci:1
             descripción: PCI bridge
             producto: 6 Series/C200 Series Chipset Family PCI Express Root Port 1
             fabricante: Intel Corporation
             id físico: 1c
             información del bus: pci@0000:00:1c.0
             versión: b4
             anchura: 32 bits
             reloj: 33MHz
             capacidades: pci normal_decode bus_master cap_list
             configuración: driver=pcieport
             recursos: irq:21 ioport:c000(size=4096) memoria:f7000000-f79fffff ioport:e4200000(size=10485760)
           *-network DESACTIVADO
                descripción: Interfaz inalámbrica
                producto: AR9287 Wireless Network Adapter (PCI-Express)
                fabricante: Qualcomm Atheros
                id físico: 0
                información del bus: pci@0000:02:00.0
                nombre lógico: wlp2s0
                versión: 01
                serie: 90:00:4e:d7:f4:35
                anchura: 64 bits
                reloj: 33MHz
                capacidades: bus_master cap_list ethernet physical wireless
                configuración: broadcast=yes driver=ath9k driverversion=4.10.0-32-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11
                recursos: irq:16 memoria:f7000000-f700ffff

...

user@vaio:~$ lspci
...
02:00.0 Network controller: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) (rev 01)
...

user@vaio:~$ lsmod

...
ath3k                  20480  0
....
ath9k                 147456  0
ath9k_common           36864  1 ath9k
ath9k_hw              466944  2 ath9k,ath9k_common
ath                    28672  3 ath9k_hw,ath9k,ath9k_common
mac80211              782336  1 ath9k
cfg80211              602112  4 mac80211,ath9k,ath,ath9k_common

user@vaio:~$ ifconfig
enp5s0    Link encap:Ethernet  direcciónHW f0:bf:97:db:be:82  
          Direc. inet:192.168.1.34  Difus.:192.168.1.255  Másc:255.255.255.0
          Dirección inet6: fd30:e69f:a01e:1:103d:60bd:f99b:88eb/64 Alcance:Global
          Dirección inet6: fd30:e69f:a01e:1:3a9d:d38c:68ae:b555/64 Alcance:Global
          Dirección inet6: fe80::86e5:86dc:3565:a047/64 Alcance:Enlace
          ACTIVO DIFUSIÓN FUNCIONANDO MULTICAST  MTU:1500  Métrica:1
          Paquetes RX:256827 errores:0 perdidos:0 overruns:0 frame:0
          Paquetes TX:151998 errores:0 perdidos:1 overruns:0 carrier:0
          colisiones:0 long.colaTX:1000 
          Bytes RX:329946661 (329.9 MB)  TX bytes:15761104 (15.7 MB)

lo        Link encap:Bucle local  
          Direc. inet:127.0.0.1  Másc:255.0.0.0
          Dirección inet6: ::1/128 Alcance:Anfitrión
          ACTIVO BUCLE FUNCIONANDO  MTU:65536  Métrica:1
          Paquetes RX:2352 errores:0 perdidos:0 overruns:0 frame:0
          Paquetes TX:2352 errores:0 perdidos:0 overruns:0 carrier:0
          colisiones:0 long.colaTX:1000 
          Bytes RX:203253 (203.2 KB)  TX bytes:203253 (203.2 KB)

user@vaio:~$ iwconfig
lo        no wireless extensions.

enp5s0    no wireless extensions.

wlp2s0    IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

user@vaio:~$  rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
1: sony-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
2: sony-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: yes

user@vaio:~$  rfkill unblock all 
user@vaio:~$  rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
1: sony-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
2: sony-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: yes

user@vaio:~$  gksudo gedit /etc/modprobe.d/blacklist-ath_pci.conf
blacklist ath_pci

user@vaio:~$  echo "blacklist ath3k" | sudo tee /etc/modprobe.d/ath3k.conf
user@vaio:~$  gksudo gedit /etc/rc.local

    modprobe ath3k
    exit 0

** (gedit:2752): WARNING **: Set document metadata failed: Establecer el atributo metadata::gedit-spell-enabled no está soportado

** (gedit:2752): WARNING **: Set document metadata failed: Establecer el atributo metadata::gedit-encoding no está soportado

** (gedit:2752): WARNING **: Set document metadata failed: Establecer el atributo metadata::gedit-position no está soportado

Restart.

Then:

user@vaio:~$  lsmod

...
ath3k                  20480  0   (<--- still there...)
....
ath9k                 147456  0
ath9k_common           36864  1 ath9k
ath9k_hw              466944  2 ath9k,ath9k_common
ath                    28672  3 ath9k_hw,ath9k,ath9k_common
mac80211              782336  1 ath9k
cfg80211              602112  4 mac80211,ath9k,ath,ath9k_common
...

Checking if its in blacklist files:

user@vaio:~$ gksu gedit /etc/rc.local 

    modprobe ath3k
    exit 0

user@vaio:~$  gksu gedit /etc/modprobe.d/ath3k.conf


    blacklist ath3k

Don't know what to do anymore ....

  • 1
    Possible duplicate of Wireless is disabled by hardware switch on sony vaio – David Foerster Aug 28 '17 at 1:19
  • Why do you blacklist ath3k? – Pilot6 Aug 28 '17 at 8:47
  • I don know. I've read all post and tried all suggested solutions, one by one, restarting every time, but nothing worked. The Wlan card is not there.... I understand it's a driver issue, but I don't know how to load another one... – LeoGagliardi Aug 29 '17 at 13:54
1

Using the ath9k driver with no options and configuring the modem to use only WPA2-PSK encryption did the trick for me.

  • Please do not post the same answer to many separate questions. If teh questions are similar enough to each other, then flag teh questions to be closed as duplicates, do not repost your answer multiple times. – Thomas Ward Dec 2 '17 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.