0

Yesterday I installed new Driver for my Soundcard and today the Sound doesn't work. I found an Answer for this Problem and I fixed it in /etc/default/grub but no when I try sudo update-grub it comes this error: */usr/sbin/grub-mkconfig: 7: /etc/default/grub: splash: not found *

This is my grup file:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

# MANUELL EINGEFUGT
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash pci=use_crs“

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="splash quiet"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that 
obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD . 
..)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports 
via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter 
to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

I add this line GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash pci=use_crs“ and commit this line out: #GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

I am using Ubuntu 16.04 LTS

Thanks for your help!

  • What was the point of changing: "quiet splash" to "splash quiet"? – George Udosen Aug 27 '17 at 14:07
  • From "quiet splash" to “quiet splash pci=use_crs“ – Jakob Aug 27 '17 at 14:11
  • 1
    Also change GRUB_CMDLINE_LINUX="splash quiet" to GRUB_CMDLINE_LINUX="" - that entry should normally be empty. – Byte Commander Aug 27 '17 at 14:17
3

Please look closely at the line

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash pci=use_crs“

You will see the should be ", perhaps you copied and pasted it from some where. Please re-write that line and use your keyboard don't copy and paste. And the line:

GRUB_CMDLINE_LINUX="splash quiet"

has its entry repeated in

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=use_crs"

Make that line:

GRUB_CMDLINE_LINUX=""

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.