1

I can't change my keyboard layout in Mate settings. Not sure what's wrong here.

I did run dpkg-reconfigure keyboard-configuration, but it did not fix the problem.

So, I set layouts to this, Dvorak + Russian: enter image description here

Then I try using the system, and every time a window opens, the layout switches to qwerty. I go to settings and see everything is correct. But when I try switching the layout, I see it cycle through the old sequence.

I right-click the menu and see the old setting: enter image description here

So I ran dpkg-reconfigure, rebooted, and now the setting file is this:

 $ cat /etc/default/keyboard
 # KEYBOARD CONFIGURATION FILE

 # Consult the keyboard(5) manual page.

 XKBMODEL="pc105"
 XKBLAYOUT="us"
 XKBVARIANT="dvorak-alt-intl"

Which is correct, but for some reason, MATE panel thinks layouts are old, and it switches it to qwerty US English every time I switch to another input box or a window. (Switch key is "caps lock", so it's not my fault either that it switches every time.)

How can I reset the settings to the old one? How can I purge the user settings for keyboard?

edit: tried removing and re-adding the English layout. It partially did work, now English layout is only one, and it does not switch on its own.

The strange thing is that I can't switch layout until I have an active cursor in a text box. In a browser I can't swich layout when no input box is focused.

  • 1
    In the 1st screenshot it seems the first line actually contains 2 layouts. So it's not Dvorak+Ru, but US+Dvorak+Ru. Try removing all the En layouts so that you end up with a Ru only. Then try adding the one En you prefer. – pomsky Aug 26 '17 at 18:46
  • It partially did work. I actually tried it before, but somehow now it fixed the 2 and independent English layouts problem. But now I can't switch layouts not having a focused text box, this is weird. – culebrón Aug 26 '17 at 18:54
  • 1
    Try changing the switch key. – pomsky Aug 26 '17 at 18:56
  • :( did not work and it actually got the 2 english layouts problem back. – culebrón Aug 26 '17 at 18:57
  • I tried re-adding the layout, it did fix it again, but switching was still broken. So I changed the switch key again, and now the layouts got broken again the same old way (en-ru-en_dvorak_alt_intl) – culebrón Aug 26 '17 at 19:00
1

Many thanks to @pomsky for pushing me to change settings and see the pattern.

The reason was the fcitx utility which lived its own life and was overriding MATE keyboard widget.

enter image description here

Solution:

$ sudo apt remove fcitx
$ killall fcitx -9
$ killall fcitx-qimpanel -9

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.