0

I have a Dell XPS-15 9560 with Windows 10 pre-installed. It has 2 graphics cards, a NVIDIA GTX 1050 and an Intel 620 Kabylake GT2.

I install ubuntu 16.04 through live-USB. The installation finishes and everything seems functional. It is using the default Intel graphics card and kernel 4.10.0-36.

When I try to shut down, this happens. I am stuck on this screen, watching these random error messages and having to force-shutdown.

Debugging:
-When I use an older kernel, there are no errors and it shuts down normally. I do get this screen on startup but no crashes/freezes.
-Ubuntu doesn't recognize the NVIDIA card right off the bat. When I install the proprietary nvidia drivers everything works across the board (I can even shutdown in kernel 4.10!) but the laptop is always using the NVIDIA card, meaning that I only have 1-2h battery life.
-HOWEVER, and this is the strangest part, when I try through 'NVIDIA X Settings'/'PRIME profiles' to change to the Intel card which WAS working perfectly before, all hell breaks loose. I get errors when I try to shut down, and failure on boot.

Why does the change of a kernel solve the first problem? Why when I update NVIDIA's drivers I can't go back to Intel? All this makes no sense..

I've tried everything, read through every post, followed any tactic suggested in similar posts to no avail. Any insight or ideas for further debugging would be welcome.

1

Open /etc/default/grub with your favorite editor . Replace GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" with GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_rev_override=1" Save and exit

Run the command: Sudo update-grub

|improve this answer|||||
  • Thanks! I'll try it out next week once I finish a project. Don't want to risk having to reinstall. Last time I tried to swap cards and got a freeze, I had to reinstall. :/ – Theo Sep 6 '17 at 21:25
  • Dude, I changed it and now EVERYTHING. WORKS. It's like a magic line! Can't tell you how much time, effort and despair you saved me. Thanks :) – Theo Sep 9 '17 at 22:26
  • Good to hear :) – Nicolas Haddad Sep 28 '17 at 17:29
  • I had a similar issue with Dell XPS 15 9560, got a black screen during startup and other random freezes during use (when it rarely doesn't get black screen during startup). Kernel 4.8 works, but 4.10 didn't work. This fixed it for me. – andho Dec 3 '17 at 22:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.