0

I'm super new to this forum and just installed Ubuntu Gnome 17.04. Previously I had Ubuntu 16.10. What I would like to ask is that if there's a way to change time format on the calendar. I did select my region the Netherlands format and went all the way through checking my time locale which is LC_TIME="nl.NL.UTF-8". My main locale for the whole system is in English (us_US.UTF-8). It does show Dutch time format but only on the login screen. Once I enter my desktop the calendar is in English. I'll attach a screen-captured image of the trouble.

screnshot

  • I don't get it. Your language is English, so the app shows English. Do you just want to change the date format at the top-panel? 25 Aug instead of Aug 25 ? – pomsky Aug 25 '17 at 11:52
  • Can you show us what the command cat /etc/default/locale outputs? – Gunnar Hjalmarsson Aug 25 '17 at 12:08
  • If you want to change the format of the date, time ,... you can do that by going to settings -> region & language -> format – Loic L. Aug 25 '17 at 12:21
  • @GunnarHjalmarsson it's already LANG=nl_NL.UTF-8 and as the matter of fact, I noticed that my whole operating system is not entirely in English. Some actually in Dutch. – user729367 Aug 26 '17 at 18:05
  • That's actually what I thought too, changing region but to no avail. I had to reconfigure the locale and put the default in English and simply configure the region and format using Dutch system. It worked on my Ubuntu 16.10 previously. @lolo – user729367 Aug 26 '17 at 18:07
2

Okay guys, I managed to get this through.

  • I went to dconf-editor and enter system/locale/region and activate "use default value". Previously before I activated it, it showed my time locale (locale | grep TIME) as LC_TIME=en_GB.UTF-8.

    Using terminal would be:

    gsettings reset org.gnome.system.locale region
    
  • Then I logged off and logged in back

The calendar appeared using Dutch system which corresponded with my regional format setting.

dconf-editor system/locale/region

|improve this answer|||||
  • Great! I was about to ask about that as the next step, but then I found your answer. – Gunnar Hjalmarsson Aug 26 '17 at 23:33
2

Just change the language support settings (gnome-language-selector)

Language support - screenshot

I tested it and it works

Calender - screenshot

|improve this answer|||||
  • I already did that to no avail. I even re-configured the locale too. Previously on my Ubuntu 16.10, I was able to set the whole system language in English and using Dutch format but now that I'm on Ubuntu Gnome 17.04, I couldn't. – user729367 Aug 26 '17 at 18:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy