2

This is the info from sudo lspci -v

00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)

Subsystem: Hewlett-Packard Company Sunrise Point-LP HD Audio 

Flags: bus master, fast devsel, latency 32, IRQ 128

Memory at b1428000 (64-bit, non-prefetchable) [size=16K]

Memory at b1410000 (64-bit, non-prefetchable) [size=64K]

Capabilities: [50] Power Management version 3

Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+

Kernel driver in use: snd_hda_intel

Kernel modules: snd_hda_intel, snd_soc_skl

I have tried installing oss and i get this error:

OSS build environment set up for REGPARM kernels

Building module osscore ld: Relocatable linking with relocations from format elf32-i386 (osscore_mainline.o) to format elf64-x86-64 (/lib/modules/4.10.0-32-generic/kernel/oss/osscore.ko) is not supported Linking the osscore module failed

Also tried, installing pulseaudio-equalizer from this post Realtek Audio Drivers for Ubuntu but didn't solve the problem.

If anybody have any other idea, please suggest.

Edit #1: This is the screenshot of alsamixer. enter image description here

3

Low sound level is most likely to be due to level settings in ALSA or Pulseaudio. If Pulseaudio is set higher than 100% will cause distortion in sound. Combine that with a low level setting in ALSA and you get low volume and distortion.

Use pavucontrol Pulseaudio Mixer to check Pulseaudio levels. Panel volume controls and other mixers don't always show all the control options.

Use command alsamixer in terminal to check/adjust ALSA levels. There are other audio mixers that show ALSA levels, but posting a screenshot of alsamixer will be best option to get more help

| improve this answer | |
  • 1
    Increasing sound over 100% in pavucontrol also helped. – subtleseeker Sep 3 '17 at 12:11
2

In the default Sound panel, increasing the output volume over 100% in the Output tab for "Speakers-Built in Audio". The maximum volume is 153% which is high enough for listening normal videos/songs.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.