1

I have a Dell XPS 13 which, by default, has a very sensitive trackpad. As you are typing, if you brush the trackpad by accident, the trackpad considers it as a click and the text insertion point jumps to wherever the mouse happens to be. I found and installed this fix for this issue:

sudo apt-get install xserver-xorg-input-libinput

However, now the scrolling is unnatural. When I use the trackpad to scroll a long document, it is the viewport that moves over the content. I want the content to move in the same direction as my fingers, just as it did before, just like on a touchscreen.

Can you explain to me what changes I should make to the files at /usr/share/X11/xorg.conf.d/ that will make this happen?

The solution proposed here did not help.

4

Edit the file /usr/share/X11/xorg.conf.d/40-libinput.conf or 90-libinput.conf depending on your HWE stack.

Add to the end of the touchpad section of the file a line

Option "NaturalScrolling" "True"

and restart the session.

The section should look this way:

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
        Option "NaturalScrolling" "True"
EndSection

You can also add Option "Tapping" "True", if you want to enable tap to click feature.

  • OP has added some specific information about how they applied your solution in a separate answer below. Would you mind including those details into your post, so that the other one can be tidied up? – Byte Commander Aug 25 '17 at 9:32
  • OK. I am adding the example. I was going to add it myself, but I was not behind a laptop with libinput at that time. – Pilot6 Aug 25 '17 at 9:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.