1

This question already has an answer here:

I have just installed ubuntu-gnome-16.04 flavor on my notebook and am quite pleased with it.

But natural scrolling was not really working. I have followed some answers on these questions:

  1. Enable natural scrolling on ubuntu 17.04 with gnome-shell
  2. Reverse two finger scroll direction (natural scrolling)?
  3. How to enable natural scrolling with mouse in 17.04?

After installing xserver-xorg-input-libinput, this answer in particular gave me what I wanted, but only until I reboot. How can I make this permanent?

Why this is not a duplicate: I am not looking for a way to run this command every time I boot ubuntu. I am looking for a proper way of change the settings without the need to run this command arbitrarily every time I boot. Specially, I am trying to avoid putting this command to change a setting anywhere it doesn't belong. I had previously managed to make it work by making the command run on by appending it to ~/.bashrc. But leaving it there felt unnatural. Maybe I am wrong, but I have the feeling this is not the proper place to make this setting change even if it does work

marked as duplicate by karel, Eric Carvalho, Yaron, Kevin Bowen, user364819 Sep 8 '17 at 21:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • @Fabby This is not really a duplicate as the intent is not to run applications on login. I don't know if commands count as applications, but my intention was to alter an option somewhere to make a simple change in configurations permanent. I feel these are different matters, albeit with similar answers – GugaFigueiredo Aug 24 '17 at 13:37
  • See askubuntu.com/questions/949323/… – Pilot6 Aug 24 '17 at 14:13
0

what I did and it works for me is to add the line

xinput set-prop 10 278 1

into the .bashrc file.

sudo nano ~/.bashrc

Thanks for sharing the answer, i found your question while I was searching how to make my mouse with a Natural Scroll

  • I initially applied the same fix, don't know if you saw my comment on this thread that was removed due to the duplicate flagging. Curiously, after this whole ordeal, the option to activate natural scrolling apeared in my touchpad settings. Since, I have undone the .bashrc fix and things have just been wroking fine – GugaFigueiredo Aug 28 '17 at 17:25
  • I got this error " property '278' doesn't exist, you need to specify its type and format" – Jadda Mar 1 '18 at 19:14
  • This link helped me maketecheasier.com/reverse-mouse-scrolling-direction-in-ubuntu – Jadda Mar 1 '18 at 19:18
  • Yes, the answer is not correct for all cases, because the id of the mouse and natural scrolling property may differ for different users – Bo rislav Mar 1 '18 at 19:23
  • You can find the actual IDs with 'xinput list' for the mouse and 'xinput list-props _mouseid' where _mouseid is the id of your mouse. – Bo rislav Mar 1 '18 at 19:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.