0

I've imported my databases on the server and I want to access them locally. The problem is I cannot. I mean the server doesn't response to my request.

I've added root to having access to "mydb" user list and I've given (granted) all privileges to it. Also I've commented bind_address in my.conf file and then I've restarted the mysql.

Still when I run this command:

telnet <ip> 3306

No response received.

Any idea how can I make a connection between my local and the database on the server?


MyTests:

  • Try this mysql -u fooUser -p -h <IP_ADD> – George Udosen Aug 23 '17 at 20:23
  • @George Should I try it from where? In the SSH or the server? Or from my local? – stack Aug 23 '17 at 20:26
  • From local as this was your intention, right? – George Udosen Aug 23 '17 at 20:28
  • Yes it is my intention, and it throws: ERROR 2013 (HY000): Lost connection to MySQL server at 'waiting for initial communication packet', system error: 2 "No such file or directory" – stack Aug 23 '17 at 20:31
  • 1
    @George Email has been sent. – stack Aug 23 '17 at 20:58
0

With problems ERROR 2003 (HY000): Can't connect to MySQL server on '88.198.86.120' (10061 "Unknown error"). You can grant permission for user root with IP 88.198.86.120(IP locally) as command:

mysql> GRANT ALL PRIVILEGES ON *.* TO root@'88.198.86.120' IDENTIFIED BY 'NbYe&er9gTdbEzVkcHJbZ$r' with grant option;

mysql> flush privileges;

If you running firewall, you should allow IP 88.198.86.120 connect to port 3306 with:

ufw allow from 88.198.86.120 to any port 3306

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.