1

I'm currently running Ubuntu Zesty. However the default Vim package does not support Python? I've already installed vim-nox as well.

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 17.04
Release:        17.04
Codename:       zesty

$ vim --version | grep python
+cryptv          +linebreak       -python          +vreplace
+cscope          +lispindent      -python3         +wildignore

Does the default Vim package support the Python plugin, or did I mess up my installation, or miss something else here?

  • Can you try installing vim-gnome/vim-gtk and see if they still have the python support enabled. – AmeyaVS Aug 24 '17 at 6:44
  • vim-nox should support python3, but not python. Python 2 support was dropped in 17.04. What does vim.nox --version report? – muru Aug 24 '17 at 6:45
  • Thanks a lot people. Just realize my vim is pointing to vim.gtk3 instead of vim.nox through sudo update-alternatives --config vim – KianMeng Ang Aug 24 '17 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.