1

So, after many and many nights spent trying to fix this, i've came to the very last option: ask here. Let me explain my problem. I have an ASUS NT7000something laptop, witch has only an HDMI output. I managed to install Ubntu 16.10 last year, after a lot of trouble because of my graphic card (NVIDIA GeForce 950 M). I used an HDMI to VGA adapter a couple of times to plug in an external monitor and it was always working fine (the same as using an HDMI monitor and an HDMI-HDMI cable). Then I updated to 17.04, and the trouble started. Using the HDMI port to connect a standard HDMI monitor still works fine, but if I tried to use an HDMI to VGA adapter nothing works anymore. I tried using different monitors, different cables and also different adapters, but nothing seems to work. Any kid of monitor won't be detected, at all. I tried to change and to update the NVIDIA drivers, also to use noveau and nomodeset but nothing. I tried deleting X10 and similar and it only made it worst. I even reinstalled completely Ubuntu after formatting my SSD, out of desperation! :(

Could it be that both the adapters I tried aren't compatible with Ubuntu? Is that even a thing??

Please help me!!! I would be eternally grateful!

Bye bye,

Giovanni

1

-- EDIT ---

I just realized I posted this without seeing that you already tried most of these steps. Leaving it up here in case it's useful to anyone. - Matt


Having been through this recently with a new monitor, I can relate to the frustation of this.

Though I can't offer a solution, I can suggest steps to diagnose.

Diagnosis steps to try:

  1. check Ubuntu displays settings. (main menu -> settings -> displays)

See if your monitor is recognized there.

  1. Check monitor is recognized by xrandr: First You can check to see if your monitor is detected at all using these commands:

    xrandr -q --verbose

You'll get some output that looks something like this:

Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 8192 x 8192
eDP-1 connected primary 1920x1080+1920+0 (normal left inverted right x axis y axis) 293mm x 165mm

1920x1080     60.00 +  59.93* 
1680x1050     59.95    59.88  
1600x1024     60.17  
1400x1050     59.98  
1280x1024     60.02  
1440x900      59.89  
[...]

Somewhere in there, you should see an HDMI connected section:

HDMI-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
1920x1080     60.00*+  59.94  
1680x1050     59.88  
1280x1024     60.02  

If not, there's probably a cable connection problem

  1. See if your monitor can be detected connected to another non-ubuntu machine using the cable adapters you have. If it's recognized there, you know your adapters are not the problem.

  2. Check your video card type: lspci | grep VGA

    I found several forum posts suggesting that there is some kind of problem with Nvidia drivers, and sometimes your system is not getting correct resolution information for your particular monitor. The solution there seems to have to do with updating the Nvidia graphics drivers.

  • BTW, with my own monitor, the issue was something about the cable adapter not being plugged in correctly, I think. I switched adapters from another machine, and it worked fine. – emf Sep 12 '17 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.