1

I'm using a HUAWEI MODEM as internet device connection at my workplace (a printing house) on a SAMSUNG DP-U250 all-in-one PC. Because many of my customers come from windows OS, I had to setup dual boot Win 10 + Ubuntu 17.04 so I can work on ubuntu during night, since I am a developper.

The Issue

The issue now comes for wifi connection that is slow, very slow, too slow when working on ubuntu. It wasn't working for Ubuntu 16.10... And from time to time, the wifi get disconnected. My MODEM is just under my PC, so I don't have any reason to think it might be the distance.

My Attempt

After I google'd the issue, I came about this accepted solution. My session crashed right after I pressed ENTER to run the command line and I had to do a manual reboot...

Only to discover that my wifi interface can see the wifi network but cannot connect. It just fails any time, prompting for password change, which I have not yet changed. To be sure, relatives with whom I share the network can still connect to internet through the same WIFI. I even deleted the connection from the connection manager but nothing. It doesn't work.

What I Need

  1. I executed the command without have first read the manual, so I'll want some links to better understand what I have done.

  2. I need a way to fix this without reinstalling ubuntu. I use to quickly reinstalling OS when I've twisted its config files too much but I want to grow a little and learn to fix my mess.

More Attempts

I was reluctant to ask a new question because I've been downvoted for almost each of the few questions I asked on stackoverflow, but chili555 took the step, encouraged me and asked for more informations. Here follows the outputs:

~$ lspci -nnk | grep 0280 -A3

02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8192E/RTL8192SE Wireless LAN Controller [10ec:8192] (rev 01)
    Subsystem: Askey Computer Corp. RTL8192E/RTL8192SE Wireless LAN Controller [144f:7160]
    Kernel driver in use: rtl819xE
    Kernel modules: rtl8192se, r8192e_pci

~$ lsmod | grep 8192

snd_hda_core           81920  4 snd_hda_intel,snd_hda_codec,snd_hda_codec_generic,snd_hda_codec_realtek
r8192e_pci            135168  0
rtllib                151552  1 r8192e_pci
rtl8192se              65536  0
rtl_pci                28672  1 rtl8192se
rtlwifi                73728  2 rtl8192se,rtl_pci
mac80211              782336  3 rtl8192se,rtl_pci,rtlwifi

~$ dmesg | grep -e 8192 -e wlp

[    0.000000] setup_percpu: NR_CPUS:8192 nr_cpumask_bits:2 nr_cpu_ids:2 nr_node_ids:1
[    0.000000] percpu: Embedded 36 pages/cpu @ffffa0893fc00000 s107992 r8192 d31272 u1048576
[    0.000000] pcpu-alloc: s107992 r8192 d31272 u1048576 alloc=1*2097152
[    0.000000]  RCU restricting CPUs from NR_CPUS=8192 to nr_cpu_ids=2.
[    0.012669] Mount-cache hash table entries: 8192 (order: 4, 65536 bytes)
[    0.012680] Mountpoint-cache hash table entries: 8192 (order: 4, 65536 bytes)
[    0.148124] pci 0000:02:00.0: [10ec:8192] type 00 class 0x028000

Thanks in advance.

  • First, it appears that you may have two possibly competing modules loaded. Let's verify. Please edit your question to add the result of: lsmod | grep 8192 – chili555 Aug 22 '17 at 23:16
1

Don't blacklist any driver you have rtl8192e.

The rtl8192e has had fixes in the last three months, unfortunately they have all missed 17.04 because none of the fixes are in kernel 4.10.

Either wait for 17.10 or install kernel 4.11 manually

Kernels fixed to date 4.04, 4.09 and 4.11+

There is one outstanding fix for 4.13 that should make it in time for 17.10 release.

0

As we see, you do have two drivers that may conflict that are loaded. Let's try blacklisting one and see if it helps. From the terminal:

sudo -i
echo "blacklist r8192e_pci"  >>  /etc/modprobe.d/blacklist.conf
modprobe -r r8192e_pci
exit

It may take a reboot. Is there any improvement?

I need a way to fix this without reinstalling ubuntu. I use to quickly reinstalling OS when I've twisted its config files too much but I want to grow a little and learn to fix my mess.

I doubt that the command does or did anything; however, to revert the ineffective change, do:

sudo rm /etc/modprobe.d/rtl8723be.conf
  • Network manager is not displaying enable wifi option, hence, do not scan available WIFI networks. But rfkill list display 0: hci0: Bluetooth Soft blocked: no Hard blocked: no i.e no wifi information – Salathiel Genèse Aug 23 '17 at 0:06
  • After a reboot, please edit your question to add the result of: dmesg | grep -e 8192 -e wlp – chili555 Aug 23 '17 at 0:12
  • I had to reboot to be sure it could not work by siply restart the system... So reboot was done. – Salathiel Genèse Aug 23 '17 at 1:01
  • Now it appears that neither driver loads!!! Confirm: lsmod | grep 8192 If neither is loaded, try: sudo modprobe rtl8192se Does the wireless spring to life? Are there any errors or warnings? – chili555 Aug 23 '17 at 1:18
  • rm: cannot remove '/etc/modprobe.d/rtl8723be.conf': No such file or directory – Salathiel Genèse Aug 23 '17 at 1:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.