0

Summary:

A computer running Ubuntu have a GeForce video card with two monitors. I need to set up the screen resolution for the second monitor, but xrandr doesn't allow it. The computer detects two screens (0 and 1) instead of one screen with double sized desktop. How do I set up the screen resolution for screen 1? (I don't want to use an extended desktop).

Scenario:

It is a computer running Ubuntu 14.04 LTS with a GeForce GTX 750 1GB ZOTAC video card, with two DVI outputs. I am using xrandr to set the resolution of the second screen. Xrandr tells me that there are two connected screens, screen 0 and 1. Both are connected by a DVI to VGA adapter.

Problem:

The main screen (screen 0) detects the correct configuration immediately. The secondary screen (screen 1) is fixed at 800x600 or at best, 1024x768, but should be at 1360x768.

I have tried turning the screen off and on and indicating the resolution immediately:

xrandr --screen 1 --output DVI-D-0 --off
xrandr --screen 1 --output DVI-D-0 --auto -s 1360x768

But the command completely ignores the setting of the definition. Or, I get an error: Badvalue (integer parameter out of range for operation) Major opcode failed request: 140 (RANDR) Minor opcode failed request: 7 (RRSetScreenSize) Value in failed request: 0x0 Serial number of failed request: 23 Current serial number in output stream: 25

Question:

How do I set up the right screen resolution (1360x768) for screen 1?

Restriction:

I want to preserve the configuration of screen 0 and 1. Many Q&A on this website talk about extending desktop on screen 0 (with virtual display or similar procedures, it is like working with one screen with double size), but I really need to preserve the screen 0 and 1 because we are using specific software.

For clarification, if I preserve the configuration I could do the following:

DISPLAY=0.1 xterm & 

and xterm will be shown on screen 1. If I use an extended desktop, it will not work.

Any advice will be welcome.

  • you need to find a resolution that both screens will accept. Some monitors will not accept a wide screen format via the VGA port. – ravery Aug 22 '17 at 23:28
  • You are right, The secondary screen is wide, but could be a monitor with resolution 1600x900 or 1366x768. It's depends on the performed experiment (the user exchange the monitor). The screen with 1600x900 work fine with wide format. – Rodrigo Eduardo Gálvez Rojas Aug 23 '17 at 12:35
0

Please follow the following steps:

  1. Define a new mode with your preferred resolution setting (cvt 1360 768 was used to compute those numbers):

    xrandr --newmode "1360x768" 84.75 1360 1432 1568 1776 768 771 781 798 -hsync +vsync
    
  2. Add this mode to your output:

    xrandr --addmode DVI-D-0 1360x768
    
  3. Force the desired mode on your output:

    xrandr --output DVI-D-0 --mode 1360x768
    

Blatantly stolen from xrandr's manpage – they really worth reading.

  • Thanks! I will try it tomorrow. Just one question: the newmode affects booth screens 0 and 1? I will try: xrandr --screen 1 --newmode ... – Rodrigo Eduardo Gálvez Rojas Aug 23 '17 at 12:32
  • @RodrigoEduardoGálvezRojas As far as I know you just need to configure the output and leave --screen out. A new mode affects neither screen or output until added to the list of valid modes for an output with --addmode, and then it still needs to be chosen with the last command. – dessert Aug 23 '17 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.