3

I know this has been asked before, but all that I've read so far to this topic couldn't help me. I'm new to Linux, so this might also be a reason that I can't get it working though I'm learning constantly.

Goal: I want to be able to change/adjust the fan speed, voltage, etc. of my Nvidia graphic cards. It's a mining rig, currently running EWBF-Miner for ZCash ([Link][1]). Mining works fine, but the GPU temperatures and power cut be lower. Both were lower when mining Ethereum with Claymore.

System: - Xubuntu 16.04 - 2 x Gigabyte GTX Geforce 1070 OC Windforce 8 GB (temperatures ~60°C - 75°C) - 2 x Asus GTX Geforce 1070 Turbo 8 GB (temperatures ~70°C - 81°C) - Mainboard MSI Z170A SLI Plus (with integrated Intel graphics adapter) - In Bios I have set PEG0 and PEG1 both to GEN1; the display has to be on IGD since I have the display connected to the integrated GPU (Can't reach the ports from the other GPUs);normally the display is not connected

Tried so far: I have tried different Nvidia drivers. The ones from ppa (different versions) . Currently the original Nvidia driver is installed (In GUI in "additional drivers" the other options are grey now=unselectable). I made the whole setup mostly following this guide. Currently I have uninstalled (purge) and re-installed the Nvidia drivers a couple of time (maybe this also had negative impact since I also receive two error messages when I boot the system). Currently I'm not even sure anymore if I have Cuda SDK v8 installed or not (I couldn't purge it).

I tried to activate Coolbits in /etc/X11/xorg.conf by manually adding to the file:

Option "Coolbits" "28"

I also tried other numbers: 1 and 31. These don't have any effect on the Nvidia X Server, so there is for example not showing up a bar to control fan speed. Also after a reboot or log-off and re-login the values I've added to xorg.conf are gone. They haven't been stored. I also tried everything mentioned in this thread. I also tried the power limits (sudo nvidia-smi -pl 30) mentioned in that thread. They actually have an effect, but are not saved after reboot. I also tried various other things which I found in the internet and which I already forgot. To me the problem seems to be that the adjustments (Coolbits settings) don't have an impact at all and they are not stored.

Currently I have no idea what to do. But before I re-install everything, including Ubuntu, I would really appreciate some advice.

Additional notes: Not sure if the graphic cards need to have a display cable (HDMI, DVI) attached or something, but when I worked on this I had the Mainboard GPU attached to a display. I try to do most operations vie OpenSSH from my Desktop computer.

Edit: For example I tried these steps without any impact (apparently can't link the source):

Here's is how I was able to enable overclocking for my 1060's on Ubuntu: Step 1 : Add the Proprietary drivers ppa sudo add-apt-repository ppa:graphics-drivers/ppa Step 2 : Update the repos sudo apt-get update Step 3 : Install the nvidia driver 381.09 beta sudo apt-get install nvidia-381 Step 4: From terminal: sudo nvidia-xconfig --enable-all-gpus sudo nvidia-xconfig --cool-bits=12 Step 5: REBOOT Step 6: Open up nVidia X Server Setting application. Go to "PowerMizer" for each card. Voila!

  • As far as I know there's no way to regulate the voltages and clock speeds of Nvidia GPUs beyond what you can find in the (latest) Nvidia graphics driver and settings manager. – David Foerster Aug 22 '17 at 18:26
  • From what I read so far in the internet you can do this by "activating" "Coolbits" in the Nvidia Driver / X Server in Linux. For some it seems to work, but I got the impression that I'm not the only one who doesn't get it working. It seems that some think that having a fake display cable attached to the GPUs is necessary, but others deny that. What I wonder most is that I can't just get this thing with Coolbits running, not even for one session although it seems to work for others. – SnoopyMania Aug 23 '17 at 6:57
  • 2
    The features unlocked by Coolbits aren't available for every hardware and every driver version. Sometimes Nvidia adds over-clocking support for new chipsets, sometimes they remove it for older chipsets or if they deem it too unreliable. You should search the old release notes for you GPU chipset for such notices. – David Foerster Aug 23 '17 at 10:09
  • with every update from nvidia functions come and go. at no point in time nvidia has supplied acceptable drivers for linux in any way. i tried drivers, scripts and anything else..even the not so smart cool bits thing...nothing ever gave me control over my hardware. I do not think nvidia is good got anything but EA games on Windows. The "PowerMizer" is a joke...I can pick between "Adaptive" and "Prefer Maximum Performance". It seems the UI designers are as useless as the nvidia devs. – John Doe Nov 20 '17 at 10:56
1

2018 Answer

To enable overclocking, run:

nvidia-xconfig --cool-bits=28

Reboot your PC. Now you can do things like:

# List all GPUs
# Set power to 100W, +1000 Mhz Mem clock offset, and +100 Mhz on GPU clock
nvidia-settings -c :0 -q gpus
nvidia-smi -i 0 -pl 100
nvidia-settings -c :0 -a '[gpu:0]/GPUMemoryTransferRateOffset[2]=1000'
nvidia-settings -c :0 -a '[gpu:0]/GPUGraphicsClockOffset[2]=100'

The adventage of this method is that you can change the power input. Potential harm risk. Proceed with careful. Source here

  • To make changes permanent: sudo nvidia-smi -pm 1 – Adrian Lopez May 17 '18 at 0:29
  • GRAPHICAL WAY: Enable the coolbits, reboot, open nvidia settings, and look for PowerMizer. You won't be able to OC the power input in graphical mode. – Adrian Lopez May 17 '18 at 0:51
0

Okay.

I found a way how to (probably) be able to overclock a Nvidia GPU on Linux.

Here is described a possible solution which I didn't try: https://www.reddit.com/r/EtherMining/comments/6gfnzi/overclocking_of_multiple_gtx_1070_cards_on_375/diq1g6c/

Instead I installed the custom mining Linux OS (Nvezos) made by the same guy that wrote the above comment on reddit: https://www.reddit.com/r/nvezos/

That was pretty easy, especially given that that guy currently offers it for free (if it keeps working well, it's definitively worth to donate something).

This custom OS enables overclocking of Nvidia cards, also you can adjust the fan speed and the maximum power. Overclocking I didn't try myself. Fan speed somehow didn't have any impact. But I could set the maximum power for GPUs and the values are stored and applied after reboot.

So basically this is what I was looking for - besides the issue with the manual fan speed settings. Overclocking I haven't tried yet, don't know if I will overclock anything all.

0

So I just about gave up on this, but eventually found a solution that worked for me. Turned out that going into the BIOS and disabling the IGD (integrated graphics card on the motherboard) solved the problem. The xorg.conf was created properly and everything worked. Of course, I couldn't use the IGD to drive my display, I had to use one of the GPUs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.