2

I am trying to install the lenovo USB-C dock's integrated ethernet interface on my ubuntu 17.04.

According to arch wiki's article on the x1 carbon (and its dock), the package r8152-dkms has to be installed. Also a similar question here is available but without answer.

So the question is: How can I get that docks ethernet adapter to work?

dmesg

engor@engorx1:~$ dmesg | grep r8152
[   22.388434] usbcore: registered new interface driver r8152
[   22.500194] r8152 4-1.1:1.0 (unnamed net_device) (uninitialized): Unknown version 0x6010
[   22.500195] r8152 4-1.1:1.0 (unnamed net_device) (uninitialized): Unknown Device

lsmod

engor@engorx1:~$ lsmod | grep r8152
r8152                  49152  0
mii                    16384  2 usbnet,r8152

ifconfig does not list it as an interface.

So what am I missing out?

4

Support of this device has been added in the 4.13 kernel.

This is the commit.

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/drivers/net/usb/r8152.c?h=v4.13-rc6&id=65b82d696b9e84fda6dd7df61801b57d3e7fb976

You can install the 4.13rc6 kernel from the mainline PPA

| improve this answer | |
  • Thanks for your answer, I tried to install with "sudo dpkg -i linux-headers-4.13.0-041300rc6-generic_4.13.0-041300rc6.201708201831_amd64.deb" but unfortunately that fails with "dkms apport: kernel package is not supported". I have to admit that I'm a newbie so consider my mistake simple. – marco Aug 22 '17 at 9:54
  • You have some dkms packages installed that don's support this kernel. You need to remove them. And you need to install not only headers. – Pilot6 Aug 22 '17 at 9:57
  • I see, but this is then another topic so I'll mark this one as solved. – marco Aug 22 '17 at 10:04
1

FWIW, here is another advise : don't forget to activate the Thunderbolt interface in the BIOS. I set up those parameters (config tab of the BIOS) :

Wake by Thunderbolt 3    : [Enabled]
Security Level           : [No Security]
Thunderbolt device       : [Enabled]
USB Device               : [Enabled]
| improve this answer | |
  • This isn't a great idea, since with security disabled any Thunderbolt device can perform DMA. For example, an attacker with physical access to the machine could dump the contents of memory while it was locked. If you're using 18.04 or newer, a better option is to use boltctl to authorise your particular dock. – James Henstridge Jun 25 '18 at 12:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.