9

I just installed Kubuntu 17.04 on a Lenovo Ideapad 320, and the Touchpad is not detected. The touchpad works fine from the Windows 10 installation already on the laptop, but is not detected at all from Kubuntu, so it seems like a driver error.

Here is the xinput output. The Logitech mouse is a USB mouse I am using in the meantime, which works fine.

$ xinput --list
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech M315/M235                        id=9    [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ EasyCamera                                id=10   [slave  keyboard (3)]
    ↳ Ideapad extra buttons                     id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]

And:

$ cat /proc/bus/input/devices | grep TouchPad

Has no output. I have also tried the psmouse-related stuff suggested here to no avail

It seems like I'm not the only one, this is posted a few other places with no answer, here and here, and maybe here

Edit:

dpkg output:

$ dpkg -i elantech...
Selecting previously unselected package 
elantech-0608-dkms.
(Reading database ... 267979 files and directories currently installed.)
Preparing to unpack elantech-0608-dkms_0.1_all.deb ...
Unpacking elantech-0608-dkms (0.1) ...
Setting up elantech-0608-dkms (0.1) ...
Loading new elantech-0608-0.1 DKMS files...
Building for 4.10.0-32-generic
Building for architecture x86_64
Building initial module for 4.10.0-32-generic
Done.

psmouse:
Running module version sanity check.
Error! Module version 69C24E88441CC55A8AC9337 for psmouse.ko
is not newer than what is already found in kernel 4.10.0-32-generic 
(69C24E88441CC55A8AC9337).
You may override by specifying --force.

depmod...

Backing up initrd.img-4.10.0-32-generic to /boot/initrd.img-4.10.0-32-
generic.old-dkms
Making new initrd.img-4.10.0-32-generic                                                      

(If next boot fails, revert to initrd.img-4.10.0-32-generic.old-dkms image)                  
update-initramfs........                                                                     


DKMS: install completed.                                                                     

Processing triggers for shim-signed (1.32~17.04.1+0.9+1474479173.6c180c6-1ubuntu1) ...   

Installing version 0.2:

$ sudo dkms install --force elantech-0608/0.2
Error! Could not find module source directory.
Directory: /usr/src/elantech-0608-0.2 does not exist.

And it is installed:

$ apt search elantech
Sorting...
Full Text Search...
elantech-0608-dkms/now 0.2 all [installed,local]
  elantech-0608 driver in DKMS format.
  • Comments are not for extended discussion; this conversation has been moved to chat. – Thomas Ward Aug 22 '17 at 17:53
  • I'd rather not wait months without my touchpad. I'll look into installing the kernel later today. Thanks for your help! – jod Aug 22 '17 at 17:55
  • Is there any news about this issue? – miguelmorales85 Feb 11 '18 at 13:23
5

Install this kernel module. It should fix the issue. Run

wget https://launchpad.net/~hanipouspilot/+archive/ubuntu/ppa/+files/elantech-0608-dkms_0.2_all.deb
sudo dpkg -i elantech-0608-dkms_0.2_all.deb

Then reboot.

You need to disable Secure Boot in BIOS to let the module load.

Another option is to install this kernel.

http://people.canonical.com/~khfeng/lp1708852/

For details see https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1708852

  • Didn't work :( rebooted and touchpad still wasn't detected. There was an error in the output, something the module version for psmouse.ko being newer than what is found in the kernel – jod Aug 22 '17 at 14:26
  • Can you post the message to your question? And also did you disable Secure Boot in BIOS? It doesn't let to load custom modules. If it is related to the module version, it is easy to fix. – Pilot6 Aug 22 '17 at 14:34
  • I did disable secure boot to install. I will disable it and try again. – jod Aug 22 '17 at 15:11
  • If there is any error, post it to your question. Maybe the version needs to be changed. – Pilot6 Aug 22 '17 at 15:12
  • dpkg output posted above. should I use --force, and if so is that an option to dpkg? – jod Aug 22 '17 at 15:14
3

I installed Ubuntu 17.10 on the yoga 720 and wrote a thorough install guide.

To get the touchpad running you have to install a newer kernel, at least the kernel 4.14.

I installed the latest kernel with this script and got the touchpad running, but then at first the networking will be broken due to a bug in the apparmor settings, you can fix this by

sudo apt install apparmour-utils
sudo aa-complain /etc/apparmor.d/sbin.dhclient

(source: https://unix.stackexchange.com/questions/397708)

  • I've installed RC8 from here: kernel.ubuntu.com/~kernel-ppa/mainline/v4.14-rc8 The touchpad started to work, no network issues. Unfortunately DisplayLink doesn't work with that kernel, so I've ended up with 2 kernels, one for touchpad when I take a laptop with me, one for DisplayLink external screens when I don't. Fun. – NeverEndingQueue Nov 8 '17 at 8:30
  • It's Lenovo Ideapad 320 (i7-8550u) – NeverEndingQueue Nov 8 '17 at 8:46
1

I have this same machine and it's been nothing but trouble. I've tried every fix I could find on the net, including compiling about 6 different kernels, to no avail. From about 4.12.5 on up my touchpad will work for a few seconds and then invariable freezes. I've tried the fixes on this page. I've tried countless iterations of GRUB_CMDLINE_LINUX_DEFAULT="i8042.reset quiet splash" in GRUB. Zilch. And on top of that, I'm still experiencing frequent total system hangs, and the wifi is 9 kinds of borked. (I can actually live with the last part if need be because it's working pretty well with a USB wifi dongle.) If anybody has anymore last-ditch suggestions, I'd love to hear them, but I'm about this close to throwing this damn thing in the lake...

  • I haven't bothered compiling different kernels yet, my wireless mouse works fine for now and I haven't had the time. As for the wifi, I've had some luck using the drivers here and creating a /etc/modprobe.d/rtl8821ae.conf file with the contents options rtl8821ae int_clear=0 fwlps=0 ips=0. I've seen people try a few other things with that .conf file, but the wifi is pretty stable now (though not perfect) and I haven't bothered to try other configurations – jod Sep 7 '17 at 14:55
  • I saw this answer after already hitting "purchase" on an Ideapad 320, and it made me run to check the retailer's return policy... However, I am very pleased to report that I have had absolutely no touchpad or wifi issues with this machine. The touchpad was in fact nonfunctional using the Ubuntu 16 LTS live disc, but worked fine with a default install of 17.10. Either Lenovo changed their hardware since September, or the wonderful Ubuntu folks fixed the software issues. I had a weird episode of slowness (in both Windows and Linux), but that mysteriously went away after a few reboots... – NumerousHats Dec 26 '17 at 21:49
0

I've tried v4.14-rc8 kernel with success, unfortunately had issues with DisplayLink drivers, so I was using external USB mouse, until resolved this today, when installed newest kernel from v4.13 line - v4.13.0-25

protected by Community Sep 4 '17 at 17:00

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.