1

I have installed Ubuntu 16.04.02 on VirtualBox 5.1.26 and have configured the VM to have a second monitor using the Guest Additions.

I want to disable the Launcher on the right-hand monitor, but disabling the launcher only disables it in the mini preview while it persists on the actual desktop. How do I fix this and is this a problem with Ubuntu or VB?

screenshot

  • See if that helps: askubuntu.com/questions/131868/… – Takkat Aug 21 '17 at 9:56
  • No, I have found the controls in settings for launcher placement. – Ben Aug 21 '17 at 11:12
  • There is something broken with the display drivers (both have the same name VBX0 where the other display should be VBX1). Try to set them up again. – Takkat Aug 21 '17 at 11:17
  • I realize that it is hard to see in this screenshot, but the 0 is actually 0" or 0 inches. I assume that virtualbox does not supply a physical dimension attribute to the guest OS. While the monitors do have the same name, they seem to be recognized as distinct entities to some extent because they display different visual information and receive different color identification labels. Also, I have reinstalled the OS for other reasons and still have the same issue on a fresh install. – Ben Aug 21 '17 at 13:01
3

I fixed the issue using the Ubuntu Unity Plugin of CompizConfig Settings Manager. On the Launcher tab there is a a Launcher Monitors setting with an option to set launcher placement to "Primary Monitor", and while Ubuntu system settings did nothing, this was effective.

CCSM Screenshot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.