0

I was following this guide to help me fix an issue where my late 2016 razer blade stealth would crash on me whenever I toggle the cap locks key but it didn't work. I did the command where it installed a bunch of these stuff

sudo apt install python3-razer razer-kernel-modules-dkms razer-daemon razer-doc

and when I tried looking up this

lsmod | grep "razerkbd"

it couldn't find it. Now whenever i restart my laptop, chrome takes a good minute to open up and some stuff even lags, like when I try opening the terminal or right clicking. I want to uninstall all those razer stuff I installed and restore my computer to how it was previously before those razer installs. I am new to Ubuntu and Linux and this is the first time I have ever installed another OS on a computer, sorry for my inexperience.

0

To uninstall, you should be able to:

Note: if these steps produce any errors, stop and do not continue.

In terminal...

xinput set-prop "AT Raw Set 2 keyboard" "Device Enabled" 1

Try your regular keyboard. If it doesn't work, stop.

sudo rm -i /etc/X11/xorg.conf.d/20-razer.conf

sudo apt-get purge python3-razer razer-kernel-modules-dkms razer-daemon razer-doc
  • I did what you told me to do but my computer is still acting up. Chrome is taking about 5 minutes to boot up and when it does, the rest of the computer acts up. I tried opening my terminal and it wouldn't and then 4 opened at the time. Any ideas? I am thinking the drivers arent uninstalled and I need to install the previous drivers. – anonuser1234 Aug 20 '17 at 20:02
  • @anonuser1234 Did you reboot the computer? Does the problem you describe happen if you log into the guest or other accounts? – heynnema Aug 20 '17 at 20:05
  • I rebooted it, and I'm logging into my own personal account – anonuser1234 Aug 20 '17 at 20:09
  • I needed to know if the problem with Chrome happens in another account than your own. – heynnema Aug 20 '17 at 20:10
  • the guest account works fine. So it's user session problem? – anonuser1234 Aug 20 '17 at 20:17
0

So I am still not sure what caused the issue but after researching a bit more, I found this

Terminal appears with much delay when shortcut is used

and did what he said

Open Startup Application and add new

  1. Add new
  2. Name : terserah
  3. Command : killall gnome-keyring-daemon
  4. Comment : terserah

And everything works as is.

Except for my cap locks crashing my computer...

  • That's not the right fix, and it will cause problems later. – heynnema Aug 20 '17 at 20:50
  • @heynnema what problems will it cause? – anonuser1234 Aug 20 '17 at 20:56
  • I would expect password or SSH problems. – heynnema Aug 20 '17 at 21:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.