I noticed that after suspend, if my laptop (Lenovo ThinkPad T470s) is on AC, the fan kicks in at 100%. If I resume suspend without AC, it works just fine. I noticed this on cold boot Ubuntu 16.04 (possibly with powertop calibrated).

hmerzic@home:~$ uname -a
Linux home 4.10.0-32-generic #36~16.04.1-Ubuntu SMP Wed Aug 9 09:19:02 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

After suspend on AC

hmerzic@home:~$ cat /proc/acpi/ibm/fan 
status:     enabled
speed:      4638
level:      auto

After suspend on battery

hmerzic@home:~$ cat /proc/acpi/ibm/fan 
status:     enabled
speed:      0
level:      auto
  • Thanks for posting, I have the same problem with a Lenovo 5th generation Carbon X1 running 16.04. I hadn't noticed that it was related to being on AC. I can't answer your question but can confirm that this is not solely about the T470s. Aug 25, 2017 at 13:31
  • 2
    I had the same issue with my T470s, with the power cable connected and in the docking station. Following this discussion, I found that there is a BIOS update, which fixed the issue for me. Nov 11, 2017 at 10:56
  • Thanks Daniel! I will definitely check that out. I did do a similar thing when I noticed the issue, but that was already a long time ago. I guess it's time for another BIOS update! :)
    – tepsijash
    Nov 15, 2017 at 15:31
  • Thinkpad t460s: UEFI BIOS 1.44 (N1CET76W), ECP 1.14 (N1CHT32W), Ubuntu 16.04, Kernel 4.19.60 => seems fixed
    – MaesterZ
    Aug 28, 2019 at 8:37

3 Answers 3


I solved it, but I would like to know why this issue was there in the first place. I tried toggling all options tuned by powertop until I noticed that the issue is gone. The option that was causing the problem was this one:

Runtime PM for PCI Device Intel Corporation Ethernet Connection (4) I219-LM

When the state is Good the following option is set (this causes the problem)

echo 'auto' > '/sys/bus/pci/devices/0000:00:1f.6/power/control';

and when it is Bad it is

echo 'on' > '/sys/bus/pci/devices/0000:00:1f.6/power/control';

Anyone knows why this causes the problem?

UPDATE: As per the comment posted by Daniel Nyga, the official BIOS update 1.20 addresses the fan issue. After following this guide, the issue seems to be resolved.


I had the same issue with my X1 carbon 4th generation (model 20fc): The cpu fan was stuck at 100% and the cpu sensor (cat /sys/class/thermal/thermal_zone0/temp) was stuck at 48 degrees.

See this kernel bug report and this duplicate. It seems to be fixed from Kernel 4.12 or 4.13 onwards, but not for everyone.

What hamzam suggested sometimes worked:

sudo sh -c "echo auto > /sys/bus/pci/devices/0000:00:1f.6/power/control"

In the end what solved the issue for me was trying an older bios versions from lenovo:

  1. Google for "bios update bootable" and your model number, X1 20fc in my case
  2. try older versions, but not too old. I just did a "binary search" until I found a version which worked (n1fur22w in my case)

Flash it unto usb (taken from this guide, also linked in hamzams answer):

geteltorito -o bios.img n1fur22w.iso
sudo dd if=bios.img of=/dev/sda bs=1M
sudo dd if=bios.img of=/dev/sda bs=1M

Yes, I needed to flash it twice.. then, reboot, press F12 and boot from USB. I needed to disable fastboot to boot from USB and also needed to enable BIOS downgrade at some point.

What was also not clear to me: a successful downgrade progress bar looks like this (you'll recognize it when you see it):


I had the same issue using Ubuntu 18.04 on my Lenovo ThinkPad T470s. Updating the BIOS seems to have fixed the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .