0

Forgive my noob-ignorance, but I tried doing the research before asking here.

I've installed Ubuntu 16.04 on an original MacBook Air and I didn't see any networks in the WiFi dropdown even though wireless seems to be on.

I don't have a wired connection, so I have to download drivers on another computer and install them manually.

I looked up my wireless card and it says that it is a Broadcom with a PCI.ID of 14e4:4328 (rev 05). Then I looked up the driver in the table and it said that I needed to use "firmware-b43-installer". In another thread, I found out that, for Ubuntu 16.04, I needed to use b43-fwcutter_019-2_amd64.deb to install the driver in broadcom-wl-5.100.138.tar.bz2.

When I install this and reboot, I still don't see any WiFi networks showing up.

Is there something else that I need to do? What other info do you need?

[EDIT] Here is the output of lspci -knn | grep Net -A3; rfkill list

02:00.0 Network controller [0280]: Broadcom Corporation BCM4321 802.11a/b/g/n [14e4:4328] (rev 05)
    Subsystem: Apple Inc. AirPort Extreme [106b:008b]
    Kernel driver in use: wl
    Kernel modules: ssb, wl
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
1
  • Please edit your question and add output of lspci -knn | grep Net -A3; rfkill list terminal command.
    – Pilot6
    Aug 20, 2017 at 8:23

1 Answer 1

0

You need to remove the erroneously installed wl driver. Run

sudo apt purge bcmwl-kernel-source

and then reboot or run

sudo modprobe b43
2
  • This solved this problem. OMG, my head was about to explode with the amount of information on this issue. :-) Now the result of the lspci command shows Kernel driver in use: b43-pci-bridge. Thank you so much @Pilot6 for your quick and accurate responses.
    – Jolurado
    Aug 20, 2017 at 16:03
  • Did this solution stand the test of time? I've been having trouble with this on an A1237, same adapter ID. I got wifi working once or twice but then after a power cycle it stopped working and shows as "Wifi Disconnected" every time. Wondering if the final post at forums.linuxmint.com/… will fix it
    – Jimadine
    Sep 29, 2017 at 15:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .