0

I am trying to build Voxelands for Ubuntu however I get a cmake error that OpenGL has failed.

What package do I install so cmake can build correctly?

This is my build error:

sayth ~/Downloads/voxelands-master-2e653e147710f4b07a7bca4a080b208c13423cba $ cmake -DRUN_IN_PLACE=1 
-- *** Will build version 1704.00 ***
-- IRRLICHT_SOURCE_DIR = 
-- IRRLICHT_INCLUDE_DIR = IRRLICHT_INCLUDE_DIR-NOTFOUND
-- IRRLICHT_LIBRARY = IRRLICHT_LIBRARY-NOTFOUND
-- Could NOT find IRRLICHT (missing:  IRRLICHT_LIBRARY IRRLICHT_INCLUDE_DIR) 
-- gettext msgfmt path: /usr/bin/msgfmt
-- GetText enabled; locales found: ja;vi;nl;pl;hy;fr;ru;ro;hu;it;pt_BR;de;jbo;es;da
-- Sound enabled
CMake Error at /usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:148 (message):
  Could NOT find OpenGL (missing: OPENGL_gl_LIBRARY OPENGL_INCLUDE_DIR)
Call Stack (most recent call first):
  /usr/share/cmake-3.5/Modules/FindPackageHandleStandardArgs.cmake:388 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake-3.5/Modules/FindOpenGL.cmake:172 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  src/CMakeLists.txt:110 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/sayth/Downloads/voxelands-master-2e653e147710f4b07a7bca4a080b208c13423cba/CMakeFiles/CMakeOutput.log".
1

That current error relating to OpenGL is probably due to the missing library libgl1-mesa-dev. This can be installed using sudo apt install libgl1-mesa-dev.

It also looks like you may have the libirrlicht-dev library missing and possibly more.

Looking at the documentation, there are a number of libraries required. It may be worth executing the following:

sudo apt install libopenal-dev libvorbis-dev libfreetype6-dev libx11-dev libirrlicht-dev libgl1-mesa-dev libjpeg-dev libbz2-dev

That should install all of the required libraries to enable you to build the application.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.