0

My laptop freezes immediately after suspend (it doesn't turn into sleep mode, it freezes just before it should. The screen goes blank but remains bright).

This only happens when the wireless connection is activated, if I disable it then the suspend is right. There is no problem with wired connection.

After fiddling and troubleshooting, I've reinstalled the OS again and found that suspend worked fine, until I have installed some recommended updates, because just after that the laptop suspend froze again. I've searched /var/log/apt/history.log and I am pretty sure the problem must be one (or some) of these updates:

Start-Date: 2017-08-19  22:20:30
Commandline: packagekit role='update-packages'
Requested-By: jorge (1000)
Install: linux-image-extra-4.10.0-32-generic:amd64 (4.10.0-32.36~16.04.1, automatic), libcapnp-0.5.3:amd64 (0.5.3-2ubuntu1, automatic), linux-headers-4.10.0-32-generic:amd64 (4.10.0-32.36~16.04.1, automatic), libmircore1:amd64 (0.26.3+16.04.20170605-0ubuntu1, automatic), libllvm4.0:amd64 (1:4.0-1ubuntu1~16.04.2, automatic), libinput-bin:amd64 (1.6.3-1ubuntu1~16.04.1, automatic), libxfont2:amd64 (1:2.0.1-3~ubuntu16.04.1, automatic), linux-image-4.10.0-32-generic:amd64 (4.10.0-32.36~16.04.1, automatic), linux-headers-4.10.0-32:amd64 (4.10.0-32.36~16.04.1, automatic), xserver-xorg-legacy-hwe-16.04:amd64 (2:1.19.3-1ubuntu1~16.04.2, automatic), linux-signed-image-4.10.0-32-generic:amd64 (4.10.0-32.36~16.04.1, automatic), libmircommon7:amd64 (0.26.3+16.04.20170605-0ubuntu1, automatic)
Upgrade: xserver-xorg-video-qxl-hwe-16.04:amd64 (0.1.4-3ubuntu3~16.04.1, 0.1.5-2build1~16.04.1), xserver-xorg-video-vesa-hwe-16.04:amd64 (1:2.3.4-1build2~16.04.1, 1:2.3.4-1build3~16.04.1), linux-image-generic-hwe-16.04:amd64 (4.8.0.52.23, 4.10.0.32.34), xserver-xorg-video-amdgpu-hwe-16.04:amd64 (1.1.2-1~16.04.1, 1.3.0-0ubuntu1~16.04.1), linux-generic-hwe-16.04:amd64 (4.8.0.52.23, 4.10.0.32.34), xserver-xorg-input-synaptics-hwe-16.04:amd64 (1.8.3-1ubuntu1~16.04.1, 1.9.0-1ubuntu1~16.04.1), libxatracker2:amd64 (12.0.6-0ubuntu0.16.04.1, 17.0.7-0ubuntu0.16.04.1), libegl1-mesa:amd64 (12.0.6-0ubuntu0.16.04.1, 17.0.7-0ubuntu0.16.04.1), xserver-xorg-hwe-16.04:amd64 (1:7.7+13ubuntu4~16.04.2, 1:7.7+16ubuntu3~16.04.1), libgbm1:amd64 (12.0.6-0ubuntu0.16.04.1, 17.0.7-0ubuntu0.16.04.1), linux-signed-image-generic-hwe-16.04:amd64 (4.8.0.52.23, 4.10.0.32.34), xserver-xorg-video-fbdev-hwe-16.04:amd64 (1:0.4.4-1build5~16.04.1, 1:0.4.4-1build6~16.04.1), libmirclient9:amd64 (0.21.0+16.04.20160330-0ubuntu1, 0.26.3+16.04.20170605-0ubuntu1), libwayland-egl1-mesa:amd64 (12.0.6-0ubuntu0.16.04.1, 17.0.7-0ubuntu0.16.04.1), xserver-xorg-input-libinput-hwe-16.04:amd64 (0.19.0-1ubuntu0.1~16.04.1, 0.25.0-0ubuntu1~16.04.1), xserver-xorg-video-vmware-hwe-16.04:amd64 (1:13.1.0-2ubuntu3~16.04.1, 1:13.2.1-1build1~16.04.1), libgl1-mesa-dri:amd64 (12.0.6-0ubuntu0.16.04.1, 17.0.7-0ubuntu0.16.04.1), xserver-xorg-video-intel-hwe-16.04:amd64 (2:2.99.917+git20160706-1ubuntu1~16.04.1, 2:2.99.917+git20170309-0ubuntu1~16.04.1), xserver-xorg-core-hwe-16.04:amd64 (2:1.18.4-1ubuntu6.1~16.04.1, 2:1.19.3-1ubuntu1~16.04.2), xserver-xorg-input-wacom-hwe-16.04:amd64 (1:0.33.0-0ubuntu1~16.04.1, 1:0.34.0-0ubuntu2~16.04.1), xserver-xorg-input-evdev-hwe-16.04:amd64 (1:2.10.2-1ubuntu1~16.04.1, 1:2.10.5-1ubuntu1~16.04.1), linux-headers-generic-hwe-16.04:amd64 (4.8.0.52.23, 4.10.0.32.34), xserver-xorg-video-nouveau-hwe-16.04:amd64 (1:1.0.12-2~16.04.1, 1:1.0.14-0ubuntu1~16.04.1), mesa-vdpau-drivers:amd64 (12.0.6-0ubuntu0.16.04.1, 17.0.7-0ubuntu0.16.04.1), xserver-xorg-video-radeon-hwe-16.04:amd64 (1:7.7.1-1~16.04.1, 1:7.9.0-0ubuntu1~16.04.1), xserver-xorg-video-ati-hwe-16.04:amd64 (1:7.7.1-1~16.04.1, 1:7.9.0-0ubuntu1~16.04.1), libinput10:amd64 (1.2.3-1ubuntu1, 1.6.3-1ubuntu1~16.04.1)
End-Date: 2017-08-19  22:21:48

Technical details:

  • Lenovo U31-70
  • Intel Core i5 5200U CPU 2.20 GHz
  • Linux 4.10.0-32-generic
  • (based on) Ubuntu 16.04.2 LTS.
  • QCA6164 802.11ac Wireless Network Adapter, Qualcomm Atheros.
  • Did you ever manage to get the BIOS update done? You might have to temporarily connect a bootable Windows disk to do it, as it can only be done from Windows. But the BIOS update really should be your next step. – heynnema Aug 19 '17 at 23:04
  • @heynnema After a day full of problems, I tell you: I installed Win just to install the BIOS update. It is done. I rererereinstalled my OS , and suspend worked (it took 13 seconds again but it is OK), but after sudo apt update and sudo apt upgrade ... let me say the shit hit the fan . Freeze again – Minkowski Aug 20 '17 at 21:43
  • Frustrating, I know. At least we know that the BIOS wasn't in our way. Thanks for taking care of that. Did the software update bring you up to 16.04.3? If so, then you got a new kernel, and that might be a clue. I'll step back for a little while to see if somebody else has more ideas than our last go around, where I thought we had it licked, ok? – heynnema Aug 20 '17 at 21:56
  • @heynnema Nop, I still have 16.04.2. Ok, and thanks for all the time you have taken on this issue. – Minkowski Aug 20 '17 at 22:02
  • @heynnema Well..... it turns out something worked(-ish)! In the bug website you pointed out I found somebody with exactly the same laptop and OS, and the patch worked (suspend is still a little slow but freeze went away!). I've detailed it a bit below. Let's hope the community finds a better solution, but I'm satisfied so far. I really thank you all your effort and time with this issue, selflessly. Kind regards (and I hope you could enjoy the eclipse :P !! ) – Minkowski Aug 21 '17 at 23:26
0

After lots of tries and troubleshooting, I finally could fix the issue (and italics come because it is not the definitive solution). @heynnema commented in this prior post that there is a bug with the wireless adapter my laptop has and Ubuntu.

For me, the solution a user proposed in that thread worked!

git clone https://github.com/Limeth/lenovo-u31-70-patches.git
cd lenovo-u31-70-patches/wireless-adapter-patch
chmod +x ./auto.sh
./auto.sh

But suspend doesn't work perfectly. It takes between 6 and 13 seconds to go to sleep, whereas the wireless is enabled. Nevertheless, when it is disabled, suspend is immediate. Therefore this is not a proper answer, but (at least for me) this was a patch so far.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.