0

I have Ubuntu 16.04 (Xenial) installed on a laptop from 2014 with 8GB of memory and a quad-core processor (Intel Pentium N3530). Once it a while, it freezes completely (I can't even move the mouse) and I must restart it.

I've recently noticed that it's related to how many tabs I have in Chrome − programs without Internet resources don't seem to impact it. The freezing is especially prone to happening when my changes to a form are being synchronised, eg in Google Docs or Quora. It also seems more impacted by tabs with frequent updates like Facebook.

Is this a problem with my network card or with my memory? I sometimes have system monitor open and the memory might only be at 50% sometimes when the freezing occurs. Sometimes I lose Internet connection while still connected to the network. I'm not sure where to dive deeper − which logs are relevant etc? What would I see there anyway?

I heard about memtest but when running it, the results were going fine until my computer inevitably froze.

I used to have an earlier version of Ubuntu and had hoped that the freezing would stop in 16.04, but I guess not.

Some diagnostics:

kokociel@kokociel-Q2550M:~$ free -h
              total        used        free      shared  buff/cache   available
Mem:           7.7G        2.4G        3.8G        463M        1.5G        4.5G
Swap:          7.9G          0B        7.9G
kokociel@kokociel-Q2550M:~$ swapon -s
Filename                Type        Size    Used    Priority
/dev/sda3                               partition   8264700 0   -1
  • Show me free -h and swapon -s. Edit that output into your question, not the comments. Why couldn't you get memtest to run? – heynnema Aug 19 '17 at 18:24
  • thanks for the tip; I couldn't recall what was wrong with memtest before − it was just that it never finished before the freezing – kokociel Aug 19 '17 at 19:43
  • Some Intel CPUs are buggy. I suggest installing intel-microcode and upgrading to the 4.10 kernel by sudo apt install linux-generic-hwe-16.04. That fixes the issue in many cases. – Pilot6 Aug 19 '17 at 19:44
  • free -h and swapon -s look fine. Please see my answer for a fix for your problem. – heynnema Aug 19 '17 at 21:05
  • Thanks @Pilot6 − it turns out I already had intel-microcode, but I updated my kernel. I did this in addition to heynnema's answer and it seems all good now :) – kokociel Aug 20 '17 at 21:58
0

You have an Intel "Bay Trail" processor that has a bug. The fix is simple.

In terminal...

We edit a startup parameter in GRUB with:

gksudo gedit /etc/default/grub

Find the line that looks like:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Change it to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_idle.max_cstate=1"

Then:

sudo update-grub

reboot

Problem fixed!

  • I've been using it for ~2½ hours now and it hasn't crashed − thank you!! :) – kokociel Aug 20 '17 at 21:56
  • @kokociel Power consumption and heating will increase with this setting, but it works. – Pilot6 Aug 21 '17 at 9:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.